16

Problem

I'm using the gorgeous package fancytikzposter to typeset my scientific posters. There I'd like to use tikzpicture to make sketches. Unfortunately the default TikZ styles are overwritten, such that I get awkwardly styled nodes.

Minimal working example

To compile, you need to obtain fancytikzposter.sty. Compile with pdflatex

\documentclass{a0poster}
\usepackage{fancytikzposter} 
\begin{document}
\begin{tikzpicture}
\initializesizeandshifts
\blocknode%
{A Ti\textit{k}Z picture}%
{
    \begin{tikzpicture}
        \draw (0,0,0) -- (1,0,0) node[below] {$y$}
            (0,0,0) -- (0,1,0) node[right] {$z$}
            (0,0,0) -- (0,0,1) node[left] {$x$};
    \end{tikzpicture}
}
\end{tikzpicture}
\end{document}

Output (cropped)

enter image description here

EDIT: Bounty goes to the one, who fixes fancytikzposter.

5
  • 2
    It's an internal issue of fancytikzposter which is completely equal to: tikzpicture in node of another tikzpicture: how to screen of from inheriting style? So the author of fancytikzposter ought fix this issue with the provided solution of Martin's answer. – Marco Daniel Jun 29 '13 at 11:56
  • @Marco Daniel: Thank you very much. Is there a way I can temporarily fix that in fancytikzposter.sty for myself, or do I have to wrap every tikzpicture I have into a savebox? – Henri Menke Jun 29 '13 at 12:01
  • 1
    Patching the package is very hard. The author provides only one big command to draw a blocknode named \drawblocknode. If you open the sty-file you will see there is a lot to do ;-). Maybe the author can optimise his code. – Marco Daniel Jun 29 '13 at 12:04
  • 3
    You can temporarily use \tikzmark macros to actually mark the places for your TikZ pictures and draw them outside the \blocknode if you can. It has a very strange construction choice for the whole thing so indeed it needs to be recoded. Here there is a recent update from that team; tex.stackexchange.com/a/120988/3235 This is also what I meant in my answer here; tex.stackexchange.com/a/116570/3235 – percusse Jul 2 '13 at 11:39
  • 1
    I don not know if it is still helpfull, but I have faced the same problem with nested tikzpicture environments using fancytikzposter. The only way I was able to not end up with the default blocknodes from tikzposter was to make use of the node options. Explicitly calling for a rectangle node with \node[rectangle, ...] for example worked for me to get rid of the default blocknodes from tikzposter. – jon86 Mar 11 '14 at 14:43
2

As given by the comment of Vedran for How to create posters using LaTeX

fancytikzposter is obsolete and tikzposter is recommended instead.

A similar comment can be found on Elena Botoeva's page

NOTE that we joined our efforts with the tikzposter team, which resulted in an improved version 2.0 of the tikzposter class that you can find in http://www.ctan.org/pkg/tikzposter. This class combines both good structure and nice layouts. The official webpage of our project is https://bitbucket.org/surmann/tikzposter/wiki/ (under construction).

I am not going to maintain this style.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.