6

I'm writing my bachelor thesis in the documentclass scrreprt.

Unfortunately I can't suppress the page numbering, till the table of contents begins. The first two pages are empty. But then LaTeX starts numerating the pages in roman from 3 to 5, such that on the table of contents page there appears a small v. In addition to that the word contents appears itself in the ToC. I want to avoid this as well.

I was of course experimenting with \pagestyle{empty} and a lot of other things I found via googling but no result was appropriate to solve my problem. This what I have so far.

\documentclass[12pt,a4paper,twoside]{scrreprt}  
\usepackage[onehalfspacing]{setspace}  
\usepackage{tocbibind}   
\begin{document}  
\pagestyle{empty}  
%%%% Title page  
\begin{titlepage}
titlepage  
\begin{center}  
\end{center}  
\pagenumbering{roman}  
\vspace*{75mm}  
\end{titlepage}  
blabla  
\newpage  
\thispagestyle{empty}  
\pagestyle{empty}  
\chapter*{Acknowledgement}  
blabla
\newpage  
\pagestyle{empty}  
%%%% summary in mother tongue  
\chapter*{summary}  
\tableofcontents  
\newpage  
\thispagestyle{empty}  
\mbox{}  
\newpage
%%%% Page numbering restarts here  
\pagenumbering{arabic}  
\pagestyle{headings}    
\chapter{introduction}

I hope I stated the problem clearly.

Edit: I found a very simple solution to the problem that the content appears in itself. The command \usepackage[nottoc]{tocbibind} suppresses that the toc appears.

  • 1
    Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. – Marco Daniel Jun 29 '13 at 13:33
  • 3
    You are working with a KOMA class. So the package tocbibind is counterproductive. – Marco Daniel Jun 29 '13 at 13:34
  • Hello Marco. I didn't know that this is counterproductive. I wanted to add the bibliography in my ToC and adding this package seemed to be the most reasonable and intuitive way to do so. Why is this counterproductive? Is this package somehow in contradiction to my ambition to suppress the page numbers till the ToC? – Simon Jun 29 '13 at 15:04
  • The KOMA-Script classes provide the class option bibliography=totoc. – lockstep Jun 29 '13 at 15:09
  • @user2534618: lockstep provides the correct way. It's not relavant to the numbering so it was mentioned in the comment. Your other issue is related to understanding of page numbers. Every page has a logical page. The value of \thepage can be different. So a simple \clearpage\pagenumbering{roman} before the command \tableofcontents will fix your issue. – Marco Daniel Jun 29 '13 at 15:15
6

When you use commands like \chapter and \tableofcontents they implicity set \thispagestyle{plain}.

You can suppress this behavior in two ways:

  • putting \thispagestyle{empty} just after each of those commands.

In this case, your MWE can be changed to:

\documentclass[12pt,a4paper,twoside]{scrreprt}
\usepackage[onehalfspacing]{setspace}
\usepackage[nottoc]{tocbibind}
\begin{document}
\pagestyle{empty}
%%%% Title page
\begin{titlepage}
titlepage
\begin{center}
\end{center}
\pagenumbering{roman}
\vspace*{75mm}
\end{titlepage}
blabla
\newpage
\chapter*{Acknowledgement}\thispagestyle{empty}
blabla
\newpage
%%%% summary in mother tongue
\chapter*{summary}\thispagestyle{empty}
\tableofcontents\thispagestyle{empty}
\newpage
\mbox{}
\newpage
%%%% Page numbering restarts here
\pagenumbering{arabic}
\pagestyle{headings}
\chapter{introduction}
\end{document} 
  • redefining \chapterpagestyle at the beginning of the file and restoring it when you want to start your pages numbered

In this case, your MWE can be changed to:

\documentclass[12pt,a4paper,twoside]{scrreprt}
\usepackage[onehalfspacing]{setspace}
\usepackage[nottoc]{tocbibind}
\begin{document}
\renewcommand\chapterpagestyle{empty}
\pagestyle{empty}
%%%% Title page
\begin{titlepage}
titlepage
\begin{center}
\end{center}
\pagenumbering{roman}
\vspace*{75mm}
\end{titlepage}
blabla
\newpage
\chapter*{Acknowledgement}
blabla
\newpage
%%%% summary in mother tongue
\chapter*{summary}
\tableofcontents
\newpage
\mbox{}
\newpage
%%%% Page numbering restarts here
\renewcommand\chapterpagestyle{plain}
\pagenumbering{arabic}
\pagestyle{headings}
\chapter{introduction}
\end{document} 

In both ways your pages are numbered starting with the 'Introduction'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.