12

This question already has an answer here:

hyperref: Wrong DVI mode driver option `dvips',(hyperref)
because pdfTeX or LuaTeX is running in PDF mode. \ProcessKeyvalOptions{Hyp}

How can i fix this error?

I m trying to compile a template of MMA journal. It is under this link MMA Template

marked as duplicate by Martin Schröder, Moriambar, TeXnician, Schweinebacke, CarLaTeX May 10 '17 at 9:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. – Marco Daniel Jun 30 '13 at 13:32
12

Class mma.cls is intended to be used with latex+dvips and contains several driver option settings:

\usepackage[dvips,a4paper,colorlinks,breaklinks,unicode]{hyperref}%backref,
\usepackage[dvips]{color}

If you want to use pdflatex, then remove options dvips.

  • it works but when i remove dvips, figures are not be shown in pdf file. – Raio Jun 30 '13 at 15:23
  • 3
    @SefaAnılSezer: The class uses \usepackage{graphicx} without options. In TeX Live and MiKTeX graphics.cfg of the distribution detects pdfTeX. Image types PNG, JPEG, PDF, JBIG2, MPS are supported. TeX Live also loads package epstopdf to support EPS images with automatic conversion to PDF. – Heiko Oberdiek Jun 30 '13 at 15:38
  • But still I am getting the same error "hyperref: Wrong DVI mode driver option `dvips',(hyperref) because pdfTeX or LuaTeX is running in PDF mode. \ProcessKeyvalOptions{Hyp}" – Sudhir Belagali Jun 11 '16 at 7:35
  • @SudhirBelagali Have you removed the option dvips anywhere from the class file, the global and local options? – Heiko Oberdiek Jun 11 '16 at 8:42
  • @HeikoOberdiek , Thank U , I have just removed dvips from my class file ,, so it is working now , Thank U again – Sudhir Belagali Jun 11 '16 at 10:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.