9

I can no longer compile files with the polutonikogreek language option to babel in TexLive 2013. Everything was fine in TL2012. There is another question showing the same problem: Ancient Greek hyphenation in LuaLaTeX but the solution given there does nto work for me. In fact, the minimal example given in the answer does not compile on my system. I just upgraded to TL2013 from TL2012 and asked the installer to bring over my old settings from TL2012. Perhaps that's the problem?

Help appreciated.

EDIT: Problem has been fixed by babel-greek maintainer in version 1.5a

  • Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. – barbara beeton Jun 30 '13 at 14:53
  • @stefano : There seems to be a new problem. Since a few days, I can no longer compile. Are you uptodate with your distribution? Do you experience errors as well? – ClintEastwood Dec 16 '13 at 8:44
6

greek.ldf 2013/05/17 v1.4

The example file in egreg's answer in question "Ancient Greek hyphenation in LuaLaTeX" breaks with greek.ldf 2013/05/17 v1.4 with LuaLaTeX because of 8-bit characters:

l.74 \DeclareTextCompositeCommand{\"}{LGR}{
                                         �}{\accdialytika}
? 
! String contains an invalid utf-8 sequence.

Using ^^-notation instead of the 8-bit characters might fix the issue.

Update: I have reported it as bug babel/4303.

Fix suggestion

The five lines with the 8-bit byte encoded in ^^-notation:

\DeclareTextCompositeCommand{\"}{LGR}{^^9f}{\accdialytika}
\DeclareTextCompositeCommand{\'}{LGR}{^^9f}{\@hiatus}
\DeclareTextCompositeCommand{\`}{LGR}{^^9f}{\@hiatus}
\DeclareTextCompositeCommand{\<}{LGR}{^^9f}{\@hiatus}
\DeclareTextCompositeCommand{\>}{LGR}{^^9f}{\@hiatus}

However, it depends, how greek.ldf was unpacked. It depends on the TeX compiler and its options, whether the 8-bit characters of the .dtx file are passed through as 8-bit characters or whether the TeX compiler converts them to the ^^-notation.

greek.ldf 2013/06/21 v1.5

This version additionally breaks with a different error:

! Undefined control sequence.
\greek@attr@polutoniko ...{\extraspolutonikogreek 

Thus I made a new bug report babel/4305.

  • It breaks also with version 1.5 recently uploaded. – egreg Jun 30 '13 at 15:59
  • Heiko, thanks for the quick answer, but I'm afraid I don't know what you mean by ^^-notation. A Google search did not bring up anything. – stefano Jun 30 '13 at 16:07
  • @Heiko: thanks for the pointers. I read both and now know a bit more about ^^xy notation. But as this stuff is still way over my head, could you (or anyone else more conversant with (Lua)TeX internals than me) confirm the following: (1) the problem is in those 4 lines (94-97) in greek.ldf that use 8 bit characters. (2) The problem could be solved (at least for LuaTeX) by replacing the troublesome characters with their appropriate equivalents in ^^-notation. If (1) and (2) are true, then the obvious question is: what are the hex code of those characters? – stefano Jun 30 '13 at 17:49
  • @stefano No, the problem is not solvable by changing the explicit 0x9F characters into ^^9f, because this combination is illegal in UTF-8. It has to do with accents inside \MakeUppercase. However, this shouldn't be needed with Unicode engines such as XeTeX or LuaTeX. – egreg Jun 30 '13 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.