According to biblatex manual (p.24), the hyphenation field in a bib-entry switches language on per-entry basis:

hyphenation field The language of the bibliography entry. The identifier must be a language name known to the babel package. This information may be used to switch hyphenation patterns and localize strings in the bibliography.

This functionality seemed to not work. I just used an example of bib base that comes with biblatex documentation to print the entire bibliography.

\documentclass[a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[german,american]{babel}
\usepackage{csquotes}
\usepackage[style=numeric,backend=biber]{biblatex}
\addbibresource{biblatex-examples.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

The bibliography contains few entries in German. However in the printed list of references they are formatted with english strings.

[8] Averroes. Drei Abhandlungen über die Conjunction des separaten Intellects mit dem Menschen. Von Averroes (Vater und Sohn), aus dem Arabischen übersetzt von Samuel Ibn Tibbon. Ed. and trans. by J. Hercz. Berlin: S. Hermann, 1869.

Per-entry language switching is provided by the GOST bundle of bst style for BibTeX. Looking through biblatex internal code, I've got an impression that biblatex needs major re-implementation in order to provide similar functionality. Or am I wrong?

  • I removed the {biber} tag because I reckon that your question is not biber-specific. – lockstep Feb 27 '11 at 16:09
  • @lockstep: And why is it bibtex specific? – Herbert Feb 27 '11 at 16:21
  • @Herbert: The {bibtex} tag is also used for questions regarding .bib files (although these are not bibtex-specific anymore). I agree that this is somewhat awkward. – lockstep Feb 27 '11 at 16:24
up vote 10 down vote accepted

Besides including hyphenation fields in your .bib file, you need to set the babel option of biblatex (presumably to autolang=other). See section 3.1.2.1 of the manual for details.

  • 1
    If you are testing with the biblatex-examples.bib you need to add british, spanish and french to the list of languages when you load babel. (Obviously not required if your own bibliography doesn't contain such language entries.) – Alan Munn Feb 27 '11 at 18:52
  • The babel option now seems to be deprecated in favour of autolang. – Andreï Kostyrka Apr 12 '16 at 17:58

Thanks. Desired result was obtained after I had modified the preamble of my example as follows

\documentclass[a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[german,british,french,spanish,american]{babel}
\usepackage{csquotes}
\usepackage[
style=numeric
,backend=biber
,babel=other
]{biblatex}
\addbibresource{biblatex-examples.bib}

The reference 8 now reads as

[8] Averroes. Drei Abhandlungen über die Conjunction des separaten Intellects mit dem Menschen. Von Averroes (Vater und Sohn), aus dem Arabischen übersetzt von Samuel Ibn Tibbon. Hrsg. und übers. von J. Hercz. Berlin: S. Hermann, 1869.

  • 5
    from my point of view, it is not correct. The bibliography should be in the same language as the main document. – Herbert Feb 28 '11 at 6:35
  • @Igor: Please consider marking my answer (or yours) as ‘Accepted’ by clicking on the tickmark below its vote count. Also, consider to choose an accepted answer for the other questions you have asked so far. – lockstep Feb 28 '11 at 7:31
  • 1
    @herbert for example in ISO 690, some strings (like volume or edition) are in the language of a cited document, others, like pagecount are in the language of the main document – michal.h21 Feb 28 '11 at 10:56
  • @michal: I know, but if I am the reader of the document, I want to read the bibliography in the same language, except the title. – Herbert Feb 28 '11 at 11:01
  • 2
    @Herbert: in my contry bibliography by tradition is formated on per basis basis. – Igor Kotelnikov Mar 1 '11 at 15:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.