2

In the example below, paragraphs 1 and 2 are not indented and are separated by some vertical space, as requested by \parindent=0pt\parskip=10pt. However, paragraph 3 reverts to the default (some parindent, no parskip).

If I enclose \footnote(...} in a group as in {\footnote(...}}, then all is well.

Is this a bug in tufte-handout.cls? It works as expected in article.cls.

\documentclass{tufte-handout}
\def\SOMETEXT{ Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.}
\begin{document}
\parindent=0pt\parskip=10pt

1.\SOMETEXT

2.\SOMETEXT\footnote{footnote text.}\SOMETEXT

3.\SOMETEXT

\end{document}

enter image description here

3

The paragraph formatting is reset when the \footnote command is used. Instead of using your \parindent=0pt\parskip=10pt lines, you'll need to modify a few other parameters. See this answer for details on how to do this.

  • Thanks. It's easier to enclose the \footnote inside a group because then the parameters are restored. – lhf Jul 3 '13 at 19:09
  • My question is why \footnote resets those parameters. – lhf Jul 3 '13 at 21:36
  • There are two sets of paragraph indentation and spacing settings: one for the main body text (\@tufte@reset@par) and one for margin notes, sidenotes, captions, and so forth (\@tufte@margin@par). Whenever Tufte-LaTeX starts to typeset margin material, it switches to the \@tufte@margin@par paragraph settings. – godbyk Jul 4 '13 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.