In my literature directory I have got some sources, where I dont have a year, when it was published. This is why I use {o.J.} as my year. Compiling the whole thing, all my dots are erased. How to show them?

Here is an example entry:

  author = {{Gabler Wirtschaftslexikon}},
  title = {Content Management System (CMS)},
  year = {{o.J. }},
  note = {Zugriffen am 03.07.2013 {\"u}ber   \url{http://webpage.de/index.html}},
  owner = {Me},
  timestamp = {2013.05.04}


How I insert my literature:


The package I am using:



Here is a link to the chicago-new.bst at pastebin: http://pastebin.com/7c8LxVwu


Deleting purify did not work. I get lots of errors then. The console tells me, the second line is the critical one.


This is how it looks, when purify is inside:

  • 1
    I believe to have already seen something of this kind; can you please add a minimal document showing the bibliography packages you're using? Perhaps Citations with no date helps, too. – egreg Jul 4 '13 at 8:53
  • Which bibliography style are you using? – oLas Jul 4 '13 at 10:02
  • The link by ereg is exactly what I am looking for, but I am using \bibliographystyle{chicago-new} for my literature. – tellob Jul 4 '13 at 10:06
  • The solution is probably the same, i.e., remove purify$, but to be sure we need to see your bibliography style. Google failed to find a chicago-new.bst. – mafp Jul 4 '13 at 15:30
  • ul.to/d7aa9qak Here you can download my bibliographystyle! Thanks so far! – tellob Jul 4 '13 at 16:11

The solution is exactly the same as in @egreg's answer in Citations with no date, e.g. (Aristotle n.d.): remove purify$ from function calc.label in line 991 of your chicago-new.bst. This will work as expected as long as an author that has an entry without year does not occur again in a multicite, i.e., \cite{CMSdef,CMSdef2}. The reason is that natbib tries to compress years in entries from the same author, so

Knuth (1975), Knuth (1976a), Knuth (1976b)

will actually come out as

Knuth (1975, 1976a, b)

You can see this problem in the first citation in the sample output. In this case, you might work around that by changing the way you cite, a few examples are given in the code below.


  author = {{Gabler Wirtschaftslexikon}},
  title = {Content Management System (CMS)},
  year = {o.J.},
  note = {Zugegriffen am 03.07.2013 {\"u}ber   \url{http://webpage.de/index.html}},
  owner = {Me},
  timestamp = {2013.05.04},
  author = {{Gabler Wirtschaftslexikon}},
  title = {Content Management System (CMS) -- Directors Cut},
  year = {o.J.},
  note = {Zugegriffen am 03.07.2013 {\"u}ber   \url{http://webpage.de/index.html}},
  owner = {Me},
  timestamp = {2013.05.04},



\citet{CMSDef}, \citet{CMSDef2}

\citet{CMSDef}, \citeyearpar{CMSDef2}

\citeauthor{CMSDef}, (\citeyear{CMSDef}, \citeyear{CMSDef2})


sample output

Regarding the problem in your third edit, check the braces in your bib file, they seem to be unbalanced.

I fixed the typo in Zugegriffen

  • Ok that works now. The problem was, that I inserted it with braces like {o.J.}. Removing the braces and emoving purify solved the problem. Thank you! – tellob Jul 6 '13 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.