4

In the following example, if I uncomment the inclusion of unicode-math, I still get an PDF that shows up fine in my PDF Viewer (Evince), but none of the equation shows up in print. Why is that?

\documentclass{scrartcl}

\usepackage{fontspec}
%\usepackage{unicode-math}
%\setmathfont{Asana Math}
% uncomment the previous two lines to get ``unprintable'' PDF

\begin{document}

magnetic constant $\mu_0 = 4\pi·10^{-7} \frac{\mathrm{H}}{\mathrm{m}}$ 

\end{document}

Edit: After updating to TL2013, the problem still persists. I guess some printer drivers have problems with the generated PDF (trying it on a Brother HL-5350DN btw). When I convert the PDF to PostScript with pdftops, the resulting *.ps file prints just fine. I'll try with my Canon printer at home later.

Edit 2: My Canon printer (MP-600R, with the default Ubuntu drivers) is doing the same thing, no equation.

Edit 3: Output of pdffonts:

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
CELWMH+LMRoman10-Regular             CID Type 0C       Identity-H       yes yes yes      4  0
TRFNXO+Asana-Math                    CID Type 0C       Identity-H       yes yes yes      5  0
GZWLZZ+Asana-Math                    CID Type 0C       Identity-H       yes yes yes      6  0
  • No problem here; LuaLaTeX and XeLaTeX, TeX Live 2013 – egreg Jul 5 '13 at 10:56
  • Hm, I'll try updating. Still on TL2012. – Psirus Jul 5 '13 at 11:05
  • @Psirus works for me: TL2012 and TL2013, LuaLaTeX and XeLaTeX, with Evince and Okular. – giordano Jul 5 '13 at 11:15
  • It shows on all PDF viewers, as far as I can tell, but when I print it (physically), the equation is missing. – Psirus Jul 5 '13 at 11:38
  • 2
    What sort of printer are you printing to? Using what driver? Have you tried ``printing as image''? – WillAdams Jul 5 '13 at 12:41
1

This is not guaranteed to work, but it is always worth trying when you have a font problem:

gs -q -dBATCH -dNOPAUSE -dSAFER -sDEVICE=pdfwrite -dSubsetFonts=true -dEmbedAllFonts=true \
   -dPDFSETTINGS=/printer -sOutputFile=out.pdf in.pdf

replacing "in.pdf" with the PDF you have, and "out.pdf" with some convenient filename.

  • Thank you for your answer, but sadly, it didn't help. – Psirus Jul 13 '13 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.