3

This is the code I am trying to run:

\documentclass{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage[english, german]{babel}
\usepackage[T1]{fontenc}
%...
\usepackage{CJK}
\newcommand{\jap}[1]{\begin{CJK}{UTF8}{min}#1\end{CJK}}
%...
\begin{document}
%...
\jap{よろしくお願いします}
%...
\end{document}

This gives error

LaTeX Font Warning: Font shape `C70/min/m/n' undefined
(Font)              using `C70/song/m/n' instead on input line 12.

(C:\MiKTeX\tex\latex\cjk\UTF8\c70song.fd)
! Undefined control sequence.
try@size@range ...extract@rangefontinfo font@info 
                                                  <-*>@nil <@nnil 
l.12 \jap{よろしくお願いします}

The entire log-file is here.

Strangely enough, it works when I run the code on say WriteLaTeX.

I would appreciate any and all help in resolving this.

5

This seems to be down a missing file in MiKTeX. On my TeX Live system, the document compiles fine with a file list

scrreprt.cls    2012/07/29 v3.11b KOMA-Script document class (report)
scrkbase.sty    2012/07/29 v3.11b KOMA-Script package (KOMA-Script-dependent ba
sics and keyval usage)
 scrbase.sty    2012/07/29 v3.11b KOMA-Script package (KOMA-Script-independent 
basics and keyval usage)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
scrlfile.sty    2012/06/15 v3.12 KOMA-Script package (loading files)
tocbasic.sty    2012/04/04 v3.10b KOMA-Script package (handling toc-files)
scrsize11pt.clo    2012/07/29 v3.11b KOMA-Script font size class option (11pt)
typearea.sty    2012/07/29 v3.11b KOMA-Script package (type area)
inputenc.sty    2008/03/30 v1.1d Input encoding file
    utf8.def    2008/04/05 v1.1m UTF-8 support for inputenc
   t1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  ot1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  omsenc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
   babel.sty    2013/05/16 v3.9f The Babel package
 english.ldf    2012/08/20 v3.3p English support from the babel system
 germanb.ldf    2008/06/01 v2.6m German support from the babel system
 fontenc.sty
   t1enc.def    2005/09/27 v1.99g Standard LaTeX file
     CJK.sty    2012/05/07 4.8.3
 MULEenc.sty    2012/05/07 4.8.3
  c70min.fd    2012/05/07 4.8.3
  c70min.fdx    2012/05/07 4.8.3

where the final two files are in tex/latex/cjk/contrib/wadalab/c70min.fd. With MiKTeX on the other hand I get the same error as in the question. The CTAN directory for CJK seems to contain the appropriate files, so a local installation should be possible. However, I think this should also be reported to Christian Schenk as I don't see why there is the discrepancy with TeX Live.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.