1

I'm trying to create my CV using latex. To do this I am trying to divide parts of my document into 3 columns and an arbitrary amount of rows. I've been using the minipage environment, but I'm given an indent in the lower rows of the document. My question is how I should get around this challenge, or if I should use another of LaTeX's environments for my cause?

Thank you in advance.

\documentclass[draft]{article}
\title{JOHN JOHNSON}
\author{CITY\\
BORN\\
TELEPHONE\\
E-MAIL}

\begin{document}
\maketitle
\footnotesize

\section*{\flushleft{EDUCATION}}
\hrule
\vspace{0.5cm}

\begin{minipage}[c]{0.15\textwidth}
2013 -- d.d
\end{minipage}
\begin{minipage}[c]{0.5\textwidth}
Masters degree in fluid mechanics
Analytical and numerical methods for a wave generated from an underwater
earthquake.
\end{minipage}
\begin{minipage}[c]{0.25\textwidth}
University of butt
\end{minipage}

\vspace{1cm}

\begin{minipage}[c]{0.15\textwidth}
2008 -- 2012
\end{minipage}
\begin{minipage}[c]{0.5\textwidth}
Bachelors degree in science, from the program physics, astronomy and 
meteorology. Specialization in physics with an emphasis on mechanics.  
analytical and numerical methods, and some lab work
\end{minipage}
\begin{minipage}[c]{0.25\textwidth}
University of butt
\end{minipage}

\vspace{1cm}

\begin{minipage}[c]{0.15\textwidth}
2005 -- 2008
\end{minipage}
\begin{minipage}[c]{0.5\textwidth}
Secondary school. A levels in mathematics, physics and computer systems
\end{minipage}
\begin{minipage}[c]{0.25\textwidth}
Silly school
\end{minipage}

\section*{\flushleft{WORK EXPERIENCE}}
\hrule
\vspace{0.5cm}

\end{document}

An image of the result:

enter image description here

  • 1
    Since you won't require indentation in your document, you could add \setlength\parindent{0pt} to the preamble. Perhaps a tabular (or similar) environment could be used instead of the minipages. – Gonzalo Medina Jul 6 '13 at 22:30
  • I added the image for you. I also removed your name from the question; you can include your name as part of your user name, so it will be displayed automatically. I hope it's OK. – Gonzalo Medina Jul 7 '13 at 2:15
1

The problem is that the first line of a paragraph (except the first one after a sectional unit) will be indented. You can prevent this individually by using \noindent, as in

\noindent\begin{minipage}{.15\textwidth}
....
\end{minipage}

or, you can suppress indentation for the whole document setting \parindent to 0pt, by adding to the preamble

\setlength\parindent{0pt}

Here's your code with some additional modifications explained below the attached image:

\documentclass{article}
\usepackage[explicit]{titlesec}

\titleformat{\section}
  {\normalfont\Large\bfseries}{}
  {0em}{\MakeUppercase{#1}}
  [\vskip5pt\hrule\vskip10pt]

\setlength\parindent{0pt}

\newcommand\CVEntry[3]{%
\par\begin{minipage}[t]{0.15\textwidth}
#1
\end{minipage}\hfill
\begin{minipage}[t]{0.5\textwidth}
#2
\end{minipage}\hfill
\begin{minipage}[t]{0.25\textwidth}
#3
\end{minipage}\par\vspace{0.5cm}%
}

\title{JOHN JOHNSON}
\author{CITY\\
BORN\\
TELEPHONE\\
E-MAIL}

\begin{document}

\maketitle
\footnotesize

\section{Education}

\CVEntry{2013 -- d.d}{Masters degree in fluid mechanics
Analytical and numerical methods for a wave generated from an underwater earthquake.}{University of butt}
\CVEntry{2008 -- 2012}{Bachelors degree in science, from the program physics, astronomy and meteorology. Specialization in physics with an emphasis on mechanics, analytical and numerical methods, and some lab work}{University of butt}
\CVEntry{2005 -- 2008}{Secondary school. A levels in mathematics, physics and computer systems}{Silly school}

\section{Work experience}

\end{document}

enter image description here

  • Since your document won't require indentation, I set \parindent to 0pt.

  • I used the titlesec package to customize the section headers: I suppressed numbering for \section, made the adjustments to automatically produce upper-cased titles, and automatically added the horizontal rule.

  • I defined a command \CVEntry with three mandatory arguments:

    \CVEntry{<dates>}{<information>}{<location>}
    

    to facilitate the entries typesetting. This environment uses three minipages with top alignment, since I am not a fan of vertically centered alignment (of course, you can revert to your original settings). This command automatically adds vertical spacing at the botoom, so you don't have to do it manually.

|improve this answer|||||
  • Thank you so much for all the help and advice Gonzalo! It's working perfectly and looking beautiful! – Daniel James Tarplett Jul 7 '13 at 11:28
  • @DanielJamesTarplett You're welcome! I'm glad I could help. Don't forget that, if you consider the answer solved your problem, you can accept it by clicking the checkmark to its left. In case of doubt, please see How do you accept an answer?. – Gonzalo Medina Jul 7 '13 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.