5

What changes (in the tex-configure file i guess) should i make to use this package in greek language? when i export it to pdflatex the text is gibberish. i think this is the relevant part

\PassOptionsToPackage{latin9}{inputenc} % latin9 (ISO-8859-9) = latin1+"Euro sign"
 \usepackage{inputenc}

\PassOptionsToPackage{greek,american}{babel}   % change this to your language(s)
% Spanish languages need extra options in order to work with this template
%\PassOptionsToPackage{spanish,es-lcroman}{babel}
 \usepackage{babel}
4

If you only need Greek, do

\usepackage[utf8]{inputenc}
\usepackage[greek]{babel}

If your TeX distribution is up-to-date this will be sufficient, provided you save your documents as UTF-8.

With an older TeX distribution (such as TeX Live 2012), one has to add

\usepackage[LGRx]{fontenc}

With much older TeX distributions something like

\usepackage[utf8x]{inputenc}
\usepackage[greek]{babel}

could work. But the best is to upgrade to the last release of the TeX system.


Note: the syntax proposed by classicthesis is surely not what I'd use; the suggested code should be the clearer

\usepackage[latin9]{inputenc}
\usepackage[american]{babel}
1

Instead of a complete upgrade, it is also sufficient to install/update the packages greek-fontenc and greek-inputenc from CTAN.

Never ever use "LGRx" as last option to fontenc. This is a "pseudo font encoding" which provides "LGR" with better definitions. Instead, you can write

\usepackage[LGRx,T1]{fontenc}

if the default font encoding should be Latin and

\usepackage[LGRx,T1, LGR]{fontenc}

if the default font encoding should be Greek.

However, I recommend \usepackage[T1]{fontenc} or \usepackage[T1,LGR]{fontenc} in connection with

 \usepackage{textalpha}. 

This avoids the "pseudo name" hack and is upwards compatible with the new babel-greek and greek-fontenc packages. (The textalpha package ensures that the comprehensive LGR definitions are loaded and makes the \textalpha ... \textOmega macros available in all font encodings.)

With LyX, just add \usepackage{textalpha} to Document>Settings>LaTeX preamble and select "Unicode [utf8] under Document>Settings>Language>LaTeX encoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.