5

I am trying to get biblatex to work. I tried different examples but finally found one from this forum. However, I always get an error on the \cite command (see latex output below)

\documentclass{article} 

\usepackage{filecontents}

\begin{filecontents*}{refs.bib}
@BOOK
    {KandR,
     AUTHOR  = "Kernighan, Brian W. and Ritchie, Dennis M.",
     TITLE   = "{The C Programming Language Second Edition}",
     PUBLISHER = "Prentice-Hall, Inc.",
     YEAR = 1988
    }
\end{filecontents*}

\usepackage{biblatex} 
\addbibresource{refs.bib} 

\begin{document} 

Hello\cite{KandR}
\printbibliography 

\end{document} 



running: /usr/local/texlive/2012/bin/x86_64-darwin/pdflatex -synctex=1 -interaction=nonstopmode --src-specials document.tex 
pdflatex> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
pdflatex>  restricted \write18 enabled.
pdflatex>  Source specials enabled.
pdflatex> entering extended mode
pdflatex> (./document.tex
pdflatex> LaTeX2e <2011/06/27>
pdflatex> Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
pdflatex> rman-x-2012-05-30, ngerman-x-2012-05-30, afrikaans, ancientgreek, ibycus, arabi
pdflatex> c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
pdflatex> h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
pdflatex> h, french, friulan, galician, german, ngerman, swissgerman, monogreek, greek, h
pdflatex> ungarian, icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, ma
pdflatex> rathi, oriya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, 
pdflatex> kurmanji, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk,
pdflatex>  polish, portuguese, romanian, romansh, russian, sanskrit, serbian, serbianc, s
pdflatex> lovak, slovenian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, 
pdflatex> welsh, loaded.
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/article.cls
pdflatex> Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/size10.clo))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/filecontents/filecontents.sty)
pdflatex> 
pdflatex> LaTeX Warning: Writing file `./refs.bib'.
pdflatex> 
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.sty
pdflatex> 
pdflatex> Package biblatex Warning: No "backend" specified, using Biber backend.
pdflatex> (biblatex)                To use BibTeX, load biblatex with 
pdflatex> (biblatex)                the "backend=bibtex" option.
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex2.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etoolbox/etoolbox.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etex-pkg/etex.sty))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/keyval.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/kvoptions.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/etexcmds.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ifluatex.sty))))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.def))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/ifthen.sty)
pdflatex> (/Users/wolfgang/Library/texmf/tex/latex/html/url.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-dm.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-compat.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/numeric.bbx
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/standard.bbx))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/cbx/numeric.cbx)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.cfg)))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/lbx/english.lbx)
pdflatex> (./document.aux
pdflatex> 
pdflatex> ! Package babel Error: You haven't loaded the option american yet.
pdflatex> 
pdflatex> See the babel package documentation for explanation.
pdflatex> Type  H <return>  for immediate help.
pdflatex>  ...                                              
pdflatex>                                                   
pdflatex> l.5 \select@language{american}
pdflatex>                               
pdflatex> ) (./document.bbl)
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.218 Hello\cite{KandR}
pdflatex>                        
pdflatex> 
pdflatex> LaTeX Warning: Citation 'KandR' on page 1 undefined on input line 218.
pdflatex> 
pdflatex> 
pdflatex> LaTeX Warning: Empty bibliography on input line 219.
pdflatex> 
pdflatex> [1{/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
pdflatex> (./document.aux)
pdflatex> 
pdflatex> LaTeX Warning: There were undefined references.
pdflatex> 
pdflatex> 
pdflatex> Package biblatex Warning: Please (re)run Biber on the file:
pdflatex> (biblatex)                document
pdflatex> (biblatex)                and rerun LaTeX afterwards.
pdflatex> 
pdflatex>  )
pdflatex> (see the transcript file for additional information)</usr/local/texlive/2012/te
pdflatex> xmf-dist/fonts/type1/public/amsfonts/cm/cmbx10.pfb></usr/local/texlive/2012/tex
pdflatex> mf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
pdflatex> Output written on document.pdf (1 page, 22927 bytes).
pdflatex> SyncTeX written on document.synctex.gz.
pdflatex> Transcript written on document.log.
running: /usr/local/texlive/2012/bin/x86_64-darwin/bibtex document 
bibtex> This is BibTeX, Version 0.99d (TeX Live 2012)
bibtex> The top-level auxiliary file: document.aux
bibtex> I found no \citation commands---while reading file document.aux
bibtex> I found no \bibdata command---while reading file document.aux
bibtex> I found no \bibstyle command---while reading file document.aux
bibtex> (There were 3 error messages)
running: /usr/local/texlive/2012/bin/x86_64-darwin/pdflatex -synctex=1 -interaction=nonstopmode --src-specials document.tex 
pdflatex> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
pdflatex>  restricted \write18 enabled.
pdflatex>  Source specials enabled.
pdflatex> entering extended mode
pdflatex> (./document.tex
pdflatex> LaTeX2e <2011/06/27>
pdflatex> Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
pdflatex> rman-x-2012-05-30, ngerman-x-2012-05-30, afrikaans, ancientgreek, ibycus, arabi
pdflatex> c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
pdflatex> h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
pdflatex> h, french, friulan, galician, german, ngerman, swissgerman, monogreek, greek, h
pdflatex> ungarian, icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, ma
pdflatex> rathi, oriya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, 
pdflatex> kurmanji, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk,
pdflatex>  polish, portuguese, romanian, romansh, russian, sanskrit, serbian, serbianc, s
pdflatex> lovak, slovenian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, 
pdflatex> welsh, loaded.
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/article.cls
pdflatex> Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/size10.clo))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/filecontents/filecontents.sty)
pdflatex> 
pdflatex> LaTeX Warning: Overwriting file `./refs.bib'.
pdflatex> 
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.sty
pdflatex> 
pdflatex> Package biblatex Warning: No "backend" specified, using Biber backend.
pdflatex> (biblatex)                To use BibTeX, load biblatex with 
pdflatex> (biblatex)                the "backend=bibtex" option.
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex2.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etoolbox/etoolbox.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etex-pkg/etex.sty))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/keyval.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/kvoptions.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/etexcmds.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ifluatex.sty))))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.def))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/ifthen.sty)
pdflatex> (/Users/wolfgang/Library/texmf/tex/latex/html/url.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-dm.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-compat.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/numeric.bbx
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/standard.bbx))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/cbx/numeric.cbx)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.cfg)))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/lbx/english.lbx)
pdflatex> (./document.aux) (./document.bbl)
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.218 Hello\cite{KandR}
pdflatex>                        
pdflatex> 
pdflatex> LaTeX Warning: Citation 'KandR' on page 1 undefined on input line 218.
pdflatex> 
pdflatex> 
pdflatex> LaTeX Warning: Empty bibliography on input line 219.
pdflatex> 
pdflatex> [1{/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
pdflatex> (./document.aux)
pdflatex> 
pdflatex> LaTeX Warning: There were undefined references.
pdflatex> 
pdflatex> 
pdflatex> Package biblatex Warning: Please (re)run Biber on the file:
pdflatex> (biblatex)                document
pdflatex> (biblatex)                and rerun LaTeX afterwards.
pdflatex> 
pdflatex>  )
pdflatex> (see the transcript file for additional information)</usr/local/texlive/2012/te
pdflatex> xmf-dist/fonts/type1/public/amsfonts/cm/cmbx10.pfb></usr/local/texlive/2012/tex
pdflatex> mf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
pdflatex> Output written on document.pdf (1 page, 22927 bytes).
pdflatex> SyncTeX written on document.synctex.gz.
pdflatex> Transcript written on document.log.
running: /usr/local/texlive/2012/bin/x86_64-darwin/pdflatex -synctex=1 -interaction=nonstopmode --src-specials document.tex 
pdflatex> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
pdflatex>  restricted \write18 enabled.
pdflatex>  Source specials enabled.
pdflatex> entering extended mode
pdflatex> (./document.tex
pdflatex> LaTeX2e <2011/06/27>
pdflatex> Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
pdflatex> rman-x-2012-05-30, ngerman-x-2012-05-30, afrikaans, ancientgreek, ibycus, arabi
pdflatex> c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
pdflatex> h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
pdflatex> h, french, friulan, galician, german, ngerman, swissgerman, monogreek, greek, h
pdflatex> ungarian, icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, ma
pdflatex> rathi, oriya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, 
pdflatex> kurmanji, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk,
pdflatex>  polish, portuguese, romanian, romansh, russian, sanskrit, serbian, serbianc, s
pdflatex> lovak, slovenian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, 
pdflatex> welsh, loaded.
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/article.cls
pdflatex> Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/size10.clo))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/filecontents/filecontents.sty)
pdflatex> 
pdflatex> LaTeX Warning: Overwriting file `./refs.bib'.
pdflatex> 
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.sty
pdflatex> 
pdflatex> Package biblatex Warning: No "backend" specified, using Biber backend.
pdflatex> (biblatex)                To use BibTeX, load biblatex with 
pdflatex> (biblatex)                the "backend=bibtex" option.
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex2.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etoolbox/etoolbox.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etex-pkg/etex.sty))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/keyval.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/kvoptions.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/etexcmds.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ifluatex.sty))))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.def))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/ifthen.sty)
pdflatex> (/Users/wolfgang/Library/texmf/tex/latex/html/url.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-dm.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-compat.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/numeric.bbx
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/standard.bbx))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/cbx/numeric.cbx)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.cfg)))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/lbx/english.lbx)
pdflatex> (./document.aux) (./document.bbl)
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.218 Hello\cite{KandR}
pdflatex>                        
pdflatex> 
pdflatex> LaTeX Warning: Citation 'KandR' on page 1 undefined on input line 218.
pdflatex> 
pdflatex> 
pdflatex> LaTeX Warning: Empty bibliography on input line 219.
pdflatex> 
pdflatex> [1{/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
pdflatex> (./document.aux)
pdflatex> 
pdflatex> LaTeX Warning: There were undefined references.
pdflatex> 
pdflatex> 
pdflatex> Package biblatex Warning: Please (re)run Biber on the file:
pdflatex> (biblatex)                document
pdflatex> (biblatex)                and rerun LaTeX afterwards.
pdflatex> 
pdflatex>  )
pdflatex> (see the transcript file for additional information)</usr/local/texlive/2012/te
pdflatex> xmf-dist/fonts/type1/public/amsfonts/cm/cmbx10.pfb></usr/local/texlive/2012/tex
pdflatex> mf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
pdflatex> Output written on document.pdf (1 page, 22927 bytes).
pdflatex> SyncTeX written on document.synctex.gz.
pdflatex> Transcript written on document.log.

Using this example: How to use biber

I get the following errors even though the backend is set to biber

running: /usr/local/texlive/2012/bin/x86_64-darwin/pdflatex -synctex=1 -interaction=nonstopmode --src-specials document.tex 
pdflatex> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
pdflatex>  restricted \write18 enabled.
pdflatex>  Source specials enabled.
pdflatex> entering extended mode
pdflatex> (./document.tex
pdflatex> LaTeX2e <2011/06/27>
pdflatex> Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
pdflatex> rman-x-2012-05-30, ngerman-x-2012-05-30, afrikaans, ancientgreek, ibycus, arabi
pdflatex> c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
pdflatex> h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
pdflatex> h, french, friulan, galician, german, ngerman, swissgerman, monogreek, greek, h
pdflatex> ungarian, icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, ma
pdflatex> rathi, oriya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, 
pdflatex> kurmanji, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk,
pdflatex>  polish, portuguese, romanian, romansh, russian, sanskrit, serbian, serbianc, s
pdflatex> lovak, slovenian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, 
pdflatex> welsh, loaded.
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/article.cls
pdflatex> Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/size10.clo))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/csquotes/csquotes.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etoolbox/etoolbox.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/etex-pkg/etex.sty))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/keyval.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/csquotes/csquotes.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/csquotes/csquotes.cfg))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex2.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/kvoptions.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/etexcmds.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/ifluatex.sty))))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/logreq/logreq.def))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/base/ifthen.sty)
pdflatex> (/Users/wolfgang/Library/texmf/tex/latex/html/url.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-dm.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-compat.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/blx-natbib.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/authoryear-icomp.bbx
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/authoryear.bbx
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/bbx/standard.bbx)))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/cbx/authoryear-icomp.cbx
pdflatex> ) (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/biblatex.cfg)))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/hyperref/hyperref.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/hobsub-hyperref.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/hobsub-generic.sty))
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/auxhook.sty)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/hyperref/pd1enc.def)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/latexconfig/hyperref.cfg))
pdflatex> 
pdflatex> Package hyperref Message: Driver (autodetected): hpdftex.
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/hyperref/hpdftex.def
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/oberdiek/rerunfilecheck.sty))
pdflatex> 
pdflatex> Package csquotes Warning: No multilingual support.
pdflatex> (csquotes)                Cannot enable multilingual quotes on input line 246.
pdflatex> 
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/biblatex/lbx/english.lbx)
pdflatex> (./document.aux) (./document.bbl)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/graphics/color.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/latexconfig/color.cfg)
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/latex/pdftex-def/pdftex.def
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/context/base/supp-pdf.mkii
pdflatex> [Loading MPS to PDF converter (version 2006.09.02).]
pdflatex> ))) (/usr/local/texlive/2012/texmf-dist/tex/latex/hyperref/nameref.sty
pdflatex> (/usr/local/texlive/2012/texmf-dist/tex/generic/oberdiek/gettitlestring.sty))
pdflatex> (./document.out) (./document.out)
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.247 ...m ipsum dolor sit amet~\cite{kastenholz}.
pdflatex>                                                   
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.248 ...o dolores et ea rebum~\cite{sigfridsson}.
pdflatex>                                                   
pdflatex> ! Undefined control sequence.
pdflatex> \biburlsetup ->\Urlmuskip 
pdflatex>                           =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
pdflatex> l.250 \end
pdflatex>           {document}
pdflatex> 
pdflatex> Overfull \hbox (7.21625pt too wide) in paragraph at lines 250--250
pdflatex> [][]\OT1/cmr/m/n/10 Kastenholz, M. A. and Philippe H. H^^?unenberger (2006). \ 
pdflatex>  Com-pu-ta-tion of method-
pdflatex> [1{/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
pdflatex> (./document.aux) )
pdflatex> (see the transcript file for additional information)</usr/local/texlive/2012/te
pdflatex> xmf-dist/fonts/type1/public/amsfonts/cm/cmbx12.pfb></usr/local/texlive/2012/tex
pdflatex> mf-dist/fonts/type1/public/amsfonts/cm/cmcsc10.pfb></usr/local/texlive/2012/tex
pdflatex> mf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb></usr/local/texlive/2012/texmf
pdflatex> -dist/fonts/type1/public/amsfonts/cm/cmti10.pfb></usr/local/texlive/2012/texmf-
pdflatex> dist/fonts/type1/public/amsfonts/cm/cmtt10.pfb>
pdflatex> Output written on document.pdf (1 page, 62794 bytes).
pdflatex> SyncTeX written on document.synctex.gz.
pdflatex> Transcript written on document.log.
  • 3
    You should use Biber rather than BibTeX or add the backend=BibTeX option to biblatex. – egreg Jul 9 '13 at 17:17
  • Maybe I should update to tex 2013 version. Even though 2012 definitely has the biblatex installed. I checked that – Jochen Jul 9 '13 at 17:31
  • In your log I see a suspicious file /Users/wolfgang/Library/texmf/tex/latex/html/url.sty which is probably the culprit. Remove it: it is from a very old package for HTML generation that is now obsolete and dangerous. Try first changing its name if you don't feel like deleting it. – egreg Jul 9 '13 at 17:31
  • 1
    Haaa! Amazing! removing the url.sty fixed the problem. Whatever it was. fantastic :-) thanks a lot! – Jochen Jul 9 '13 at 17:34
5

The first error reported, that is

! Package babel Error: You haven't loaded the option american yet.

See the babel package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.5 \select@language{american}

is probably due to the fact that you removed the line \usepackage[american]{babel} for producing the minimal example. Indeed there's no trace of it any more in the later runs of pdflatex.

The second problem is

running: /usr/local/texlive/2012/bin/x86_64-darwin/bibtex document 
bibtex> This is BibTeX, Version 0.99d (TeX Live 2012)
bibtex> The top-level auxiliary file: document.aux
bibtex> I found no \citation commands---while reading file document.aux
bibtex> I found no \bibdata command---while reading file document.aux
bibtex> I found no \bibstyle command---while reading file document.aux
bibtex> (There were 3 error messages)

Since you are using biblatex the default tool for processing the .bib file is biber rather than bibtex. So either you use biber or specify

backend=BibTeX

in the options to biblatex (it's recommended switching to biber, though).

The third error is

! Undefined control sequence.
\biburlsetup ->\Urlmuskip 
                         =0mu plus 3mu\relax \mathchardef \UrlBigBreakPenal...
l.218 Hello\cite{KandR}

This is due to a bogus url.sty file that you have in

/Users/wolfgang/Library/texmf/tex/latex/html/url.sty

and with high probability is an infamous url.sty that an old package for HTML conversion from LaTeX provided. Remove the entire html folder. If you don't feel like deleting it, make a ZIP archive of it and then remove the folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.