22

I'm using XeLaTeX for my document and want to style my title page. The problem is, that \maketitle make a large top space, my text begins ca. 10 cm from the top. How can I reduce this space? In the moment it looks very crimped at the bottom.

Here's the explicit code:

\documentclass[a4paper,12pt,twoside,ngerman]{article}
\parindent0pt
\parskip6pt
\usepackage{fontspec}
\usepackage{lmodern}
\usepackage{microtype}

\setmainfont[Path = fonts/,
    BoldFont = akko-w01-bold.ttf,
    ItalicFont = akko-w01-italic.ttf,
    BoldItalicFont = akko-w01-bold-italic.ttf
 ]{akko-w01-regular.ttf}

\usepackage[ngerman]{babel} % Paket für die neue deutsche Rechtschreibung
\usepackage[...]{hyperref}
...
\title{Title}
\date{}
\author{}
\begin{document}
\input{./acronyms}
\input{./glosaries}
\maketitle
\thispagestyle{empty}
\begin{center}
\textbf{{\large Thesis}}\\
\ \\
von

Name Name\\
aus City

Matrikel-Nr.: Number

{\today}\\
\ \\
\ \\
\textbf{{\large University}}

University long

University subtitle

Vorgelegt bei

\textbf{Name of the prof}

\ \\
\textbf{{\large company}}

department

city
\end{center}


\begin{minipage}{.5\textwidth}
  \begin{flushleft}
    \includegraphics[width=0.9\linewidth]{images/university.png}
  \end{flushleft}
\end{minipage}%
\begin{minipage}{.5\textwidth}
\begin{flushright}
    \includegraphics[width=0.9\linewidth]{images/company.png}
\end{flushright}
\end{minipage}
24

Include the \vspace command in the title command, i.e. change the line

\title{Title}

into

\title{\vspace{-2cm}Title}
  • it works too, used this way because the (rest) content is moved up too :) – lis Jul 10 '13 at 8:12
  • 4
    and you can change the spaces around date/author as well and you don't need additional packages. – bene Jul 10 '13 at 8:22
  • 1
    just saved the day for me! Thanks a lot. The answers here tex.stackexchange.com/questions/29593/… simply sound useless after reading your answer, no offence! – user84482 Aug 9 '15 at 18:42
15

The titling package can help you in this.

From its documentation:

The ti­tling pack­age pro­vides con­trol over the type­set­ting of the \maketi­tle com­mand

In your case, adding these lines in the preamble (adjust -3cm to your needs) should do what you want:

\usepackage{titling}
\setlength{\droptitle}{-3cm}

Have a look at the documentation for more options (e.g. spacing after the title)

  • 1
    For making a frontispiece, I would however use the titlepage environment, as you can see in these answers of mine: answ1 and answ2, or in several other answers in this site. I think you have more flexibility with it. :-) – karlkoeller Jul 10 '13 at 9:14
  • I've added \setlength{\droptitle}{-3cm} and latex refuses to add a second page to the document, always errors with undefined control sequence \end{document} as soon as the text exceeds one page – msrd0 May 26 '18 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.