35

I'm using Jabref to manage my Bibliography.

Sometimes, I put directly:

First Author et al.

when adding the article author's name in Jabref.

When compiling my .tex file, LaTeX doesn't recognize the et. al as more names. It takes it as a name/surname.

This is an example of a Bibliography entry in Jabref.

@ARTICLE{Wolf2003,  
  author = {Wolf, K.et al.},  
  title = {Compensation mechanism in tumor cell migration: mesenchymal–amoeboid
    transition after blocking of pericellular proteolysis},  
  journal = {J. Cell Biol.},  
  year = {2003},  
  volume = {160},  
  pages = {267–277},  
 }

This is a .texMWE with the bib entry mentioned:

\documentclass[11pt]{book}  
\usepackage{cite}  
\bibliographystyle{unsrt}
\begin{document}  
Here is the bib entry mentioned\cite{Wolf2003}  

\bibliography{bibfile} 
\end{document}

Here's the output:

Output of the <code>.tex</code> MWE mentioned above How can I solve this problem?

  • 18
    You should use the special keywords and others, so author={Wolf, K. and others}, – egreg Jul 11 '13 at 14:34
  • I used "{random authors}" in author field, that way you can use anything you like... I guess it's the same as egreg said :) – dingo_d Jul 11 '13 at 14:38
  • I didn't understand what you mentioned about {random authors} @dingo_d What did you mean? Thank you. – Josh Jul 11 '13 at 14:40
  • Just put what ever you want inside {} brackets ;) – dingo_d Jul 11 '13 at 14:54
59

The input conventions of BibTeX are rather strict; multiple authors must be separated by the and keyword:

author={Alpher, Ralph and Bethe, Hans and Gamow, George}

or, if you want to keep only initials,

author={Alpher, R. and Bethe, H. and Gamow, G.}

If you want only the first author and automatically add et al. in the bibliography, use the others keyword:

author={Alpher, R. and others}
| improve this answer | |
  • 1
    et doesn't want the "dot". It is Latin and means and. al. stays for alii, aliae, alia and alios, hence you shorten it and put the "dot". – Atcold Feb 17 '15 at 21:28
  • 2
    @Atcold Thanks, it was just a typo, I don't know how it slipped in and I'll remove it. I can ensure you that I know Latin. ;-) – egreg Feb 17 '15 at 21:29
5

I imagine two reasons for you to ask this question:

  1. You only have partial information about your references → use egreg's great answer in this case.
  2. What you really want is how to display one author name only in your bibliography/citation. (You here thus face a X/Y problem.)

The solution below answer this second question.


I would suggest you to keep as much information as possible in your database (in the event that you change your mind later or in another document).

To show only one author name in your bibliography, you can use features of you bibliographical package. With the package biblatex, the relevant option is maxnames=<maximal number of authors to display>.

enter image description here

\documentclass{article}

    \usepackage[
        maxnames=1,%<---------- the key option
        style=authoryear-comp,
    ]{biblatex}
    \addbibresource{\jobname.bib}

    \usepackage{filecontents}

    \begin{filecontents}{\jobname.bib}
        @book{keyone,
            author = {Single Author, A.},
            year = {2001},
            title = {Title},
            publisher = {Publisher},
        }
        @book{keytwo,
            author = {Firstof Threeauthors, J. and Secondof Threeauthors, E. and Thirdof Threeautors, G.},
            year = {2017},
            title = {A catchy title},
            publisher = {Same publisher},
        }
    \end{filecontents}

\begin{document}
    First reference: \cite{keyone}. Second one: \cite{keytwo}.

    Which are these references' authors? \citeauthor{keyone} and \citeauthor{keytwo}, respectively.

    \printbibliography
\end{document}

Note that you can differentiate between the number of authors listed in a citation (option maxcitenames=), and in the bibliography (maxbibnames=). The option maxnames= just sets both of these options together.

If you have max[x]names > 1, you might want to specify the fallback number of cited names if your reference contains more than max[x]names authors. In other words, define:

If my reference has x authors or less, then cite all of them. Otherwise, cite only the y first authors, and append 'et al'.

For that, you can use the minnames= option:

    \usepackage[
        maxnames=<x>,
        minnames=<y>,
    ]{biblatex}

Obviously, one assume x >= y. And similarly, you can define mincitenames and minbibnames separately.

Example with maxnames=2, minnames=2 enter image description here

Same example with maxnames=2, minnames=1

enter image description here

| improve this answer | |
0

We know that et al. is Latin, and should thus appear in italic.

Thing is author={Alpher, R. and others} generates et al. as a normal font and not italic.

A quick, also dirty fix, modified from the above is the following:

author = {Smith {\textit{et al.}}, Fred}
| improve this answer | |
  • The bibliography style should choose the typesetting style of the phrase resulting from and others. This should not be set in the .bib file. – Andrew Swann Jun 10 '19 at 9:05
-3

Using suggestions above, I found that this works.

To write Fred Smith et al. I used author = {Smith {et al.}, Fred}

| improve this answer | |
  • 4
    Welcome to TeX.SX! And thank you for providing an answer to this question. At the same time, if your suggestion might "work" (in the sense that you see what you're expecting), your answer is "wrong". Indeed, "Smith et al." is not the name of the author; so it's not correct to store such information in the database. What you propose is thus a quick (and dirty) fix that might work, rather than a sustainable solution. (Nothing personal here: just a note for future readers.) – ebosi Jun 23 '17 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.