I am trying to run some fonts named IPAexMincho in latex under win 8 using MikTeX under TeXnic, but I got error messages in regard to not being able to run Kanji map when I have the following valid settings (well, valid in the sense that I tried them out with other installed fonts and they just appeared to work find.

helo word.

So when I do XeLaTeX , the resulting pdf does not even get generated.

The specific warning messages I get

xelatex> Warning Couldn't open font map file "kanjix.map".
xelatex> Warning Invalid glyph name index number : 12502 (>= 12495)
xelatex> Warning Invalid version 2.0 'post' tabe
xelatex> Error Could not obtain necessary font info

I of course obtain three other warnings XeLaTeX to xparse/refedefine-command but I don't think that those are crucial for this problem.

Yes, I know there are similar seemingly helpful posts here

xetex complains about missing kanjix.map

and some posts related to setting a new fonts in the main text. The problem though is that with other Japanese fonts, I seem not to have this problem.



  • Update: when i use option LUaLATEX--> PDF instead of XeLATEX-->PDF I seem to be able to generate the pdf. WHy ? ANy hints, comments and suggestions are greatly appreaciated. – Tom Jul 13 '13 at 4:55
  • I am never able to get XeLaTex to work for me, but when I use LuaTeX, it works as well. I always receive that same error about missing fonts. – dustin Jul 13 '13 at 8:14

It sounds as if you do not have the font correctly installed: looking for a map file indicates that XeTeX did not find it using the system font approach.

For me, everything works correctly if I do the following:

  • Download the font from the supplier
  • Unzip and install to the system fonts folder
  • Tun your example using XeLaTeX from MiKTeX 2.9 or TeX Live 2013

I have Windows 7, but that should make very little difference here.

  • 1
    xelatex always loads the map files mentioned in dvipdfmx.cfg. And while it is a small nuisance that it warns that it couldn't find kanjix.map it is not related to problem (which sounds as if the font is defective). – Ulrike Fischer Sep 16 '13 at 15:01
  • 1
    @UlrikeFischer Do my instructions at least work for you? If so, I'll edit the answer to reflect the point you make but leave it here: if however it fails I'll remove. – Joseph Wright Sep 16 '13 at 17:08
  • 1
    Well they ask to accept some license so I didn't try. But reinstalling the font is certainly a good idea as the version used by the OP seems to be faulty. – Ulrike Fischer Sep 16 '13 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.