I' using the following code to create the table of contents, list of figures, and so on:


\usepackage[T1]{fontenc} % high quality pdf
\usepackage{ucs} % unicode for mac os x
\usepackage{geometry} % Flexible and complete interface to document dimensions.
\usepackage{epstopdf} % eps to pdf
\usepackage{rotating} % rotate stuff
\usepackage{lmodern} %Type1-font for non-english texts and characters
\usepackage{graphicx}        % standard LaTeX graphics tool when including figure files
\usepackage{multicol}        % used for the two-column index
\usepackage[bottom]{footmisc}% places footnotes at page bottom, etc.


%% Use of Times New Roman font

\loadglsentries{001-acronyms}   % Load list of acronyms
\loadglsentries{001-symbols}        % Load list of frequent symbols


\addcontentsline{toc}{chapter}{List of Figures} 
\addcontentsline{toc}{chapter}{List of Tables}

The \tableofcontents generates two pages, but the page number only appears on the second page. Since other commands (\listoffigures, \listoftables, \lstlistoflistings) only generate one page, the page number doesn't appear at all. I would like to have page number present on all this pages. Is there any way to achieve this?

  • 1
    Welcome to TeX.SX! This is not the normal behavior. We need to see more of the preamble; in particular the class you're using. Are you using fancyhdr? As an aside, using \include for the cover page doesn't seem best; use \input.
    – egreg
    Jul 15, 2013 at 22:46
  • Hello, I'm not using fancyhdr, I've tried to follow some suggestions with this class but still had the same problem. I will follow your advice and change it to input, thank you!
    – aumanets
    Jul 15, 2013 at 23:07
  • I get the page number bottom right.
    – egreg
    Jul 15, 2013 at 23:23

2 Answers 2


This is a very common "problem" that typically follows document classes - not specific to svmono - that provide \chapters. The reason for this stems from the fact that the layout of the header on these chapter-first-pages typically look weird, and therefore is set in a different style via something like \thispagestyle{<chapter-page-style>} (typically <chapter-page-style> is plain).

While it is possible to issue


in order to update the forced <chapter-page-style> style to <style> works for regular chapters, it's not that easy for List-of "chapters" like \tableofcontents, \listoffigures and the like. The reason for this is because the List-of chapter is set as a whole, thereby making it difficult to insert \thispagestyle{<style>} at the appropriate (timed) location.

You can resolve this problem through a patch of the List-of commands (using etoolbox):

\usepackage{etoolbox}% http://ctan.org/pkg/etoolbox
% \patchcmd{<cmd>}{<search>}{<replace>}{<success>}{<failure>}

or by letting the empty page style be equivalent to the plain page style:


Either of the above, inserted in the preamble somewhere should work.

  • The page number is there.
    – egreg
    Jul 16, 2013 at 0:05
  • Using the second example, the pages show but not in all document. It seems like your first example (patch) works better in my case, but is there any way to hide/remove page number from the cover page? Thank you
    – aumanets
    Jul 16, 2013 at 8:38

The svmono class is not free and should be used only for submissions to Springer. So either you are preparing a submission and should not tamper with the settings of the class, or you're misusing it.

There is nothing in the svmono.zip file that can only be downloaded from Springer that grants permissions to use the files for other purposes. So one must assume no permission.

In any case, the class defines

                         \csname cl@chapter\endcsname


 \fi\chapter*{\contentsname \@mkboth{{\contentsname}}{{\contentsname}}}

(similarly for \listoffigure and \listoftables). Since we find


the page number in all chapter starting pages appears at the bottom right of the page, which is what I obtain running your example.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .