I have just followed the method of Speravir (see How to use Xindy with MiKTeX?). My MiKTeX installation is D:\MiKTeX 2.9, and I already had a D:\LocalTeXMF for files that are not in the distribution. Unfortunately, trying to test with the example file (that I named testxindy.tex) and to use xindy on the resulting .idx file from the command line, it didn't work.

One reason is that it is not quite clear for the novice which executable to use in which case. Schematically, there are two possibilities for the (simplest) command line:

1) texindy.exe testxindy.idx

2) tex2xindy.exe testxindy.idx

In the 1st case, the answer was: failed to find script. The documentation mentions a makeindex4 wrapper for xindy. Unfortunately, this wrapper can't be found in the distribution. Is it some obsolete wrapper?

In the 2nd case, the answer was: writing attribute names to file testxindy.idx, the program seeming either to be waiting for some answer or to have an endless loop.

Finally, it worked launching directly the texindy.pl script. However there were strange things in the .ilg file (strange to me, at least):

Loading module YcBEHsZUlK ........ Finished loading module YcBEHsZUlK

All other modules loaded have 'normal' names… So ? Could it be related to the fact that my editor uses utf8 encoding?

Anyway I can't understand how to make the .exe files work, which, I guess, is the normal way.

Subsidiary question: in a MiKTeX installation, shouldn't the bin directory be in \LocalTeXMF\miktex\bin rather than in \LocalTeXMF\bin? If so, where should really be texmf.cnf – \LocalTeXMF or \LocalTeXMF\MiKTeX, or even \LocalTeXMF\MiKTeX\config?

I would be very grateful for any help.

  • 1
    Imho your point of view is wrong: You can't install xindy in miktex. You can allow xindy to use miktex roots as "TEXMFVAR" etc but beside this you are actually trying to install xindy independantly. I don't see which use it can have to install xindy in a root managed by miktex. Jul 16 '13 at 12:16
  • Well I considered installing xindy in a LocalTeXMF directory, just as I install there packages not in the MiKTeX distribution or personal packages or MiKTeX-biber-bin, since there is no MiKTeX-biber-bin-x64. My point is only to make all this stuff work correctly together with MiKTeX. Xindy itself uses a texmf.cnf which I do not really understand. So I scrupulously followed the instructions given in "How to use xindy with miktex". Do you think it is such a wrong point of view?
    – Bernard
    Jul 16 '13 at 15:17
  • Could it be that non-working of the .exe files come from the fact that I have a perl 64 bits installation, not a 32 bits ?
    – Bernard
    Jul 16 '13 at 17:43
  • Hmmm, I had not noticed this question. Otherwise I would have changed the approach earlier I guess.
    – Speravir
    Jan 25 '14 at 22:39

You have two possibilities get a working xindy:

  1. Install a more or less larger part of TeXLive 2013. Add to path variable the path to texlive after the path to miktex and hope that the systems don't is no interfere. (If they are problems you can change the path variable locally when switching between xindy and miktex applications (in a good editor you can add such path switches in the application calls) or delete all unneeded binaries in the texlive bin folder).

  2. Install only xindy. With the w32tex.org version it hopefully works like this:

    • Get xindy-w32.tar.xz and web2c-w32.tar.xz.
    • Unpack xindy completly and only the share folder from web2c somewhere outside miktex. If you didn't do it during the unpacking: Merge the share folder of web2c with the one of xindy.
    • Add the bin folder to your path variable
    • Create a environment variable texmf which points to the texmf-dist folder e.g. texmf=F:\Install\Xindy\share\texmf-dist.
    • check that you have a working perl by testing perl --help in the command line
    • test xindy --help in the command line.
  • I tried solution 2. Unfortunately if perl --help works perfectly, xindy --help delivers the same message :
    – Bernard
    Jul 19 '13 at 13:17
  • Sorry for the preceding trials: 5 minutes are quite short. I tried solution 2, as I had tried solution 1 by myself previously, and it made a real mess with MiKTeX . Unfortunately, if perl --help works perfectly, xindy --help delivers the same message: Failed to find script. I even experimented, changing separators for paths to /, &c., but it didn't help. I'm not even sure whether the message refers to a script wrapper – which doesn't exist – or to the perl scripts themselves — which work perfectly well if I launch them from the command line. So I really don't what to change.
    – Bernard
    Jul 19 '13 at 13:30
  • Ulrike: I didn't have enough space to thank you for your answer. So here it is — after the battle, as we say in french.
    – Bernard
    Jul 19 '13 at 13:32
  • @Bernard: Did it work or not? (It worked fine for me - I tested it! and the crucial step was the environment variable texmf). Jul 19 '13 at 14:03
  • No, it didn't. There is an ambiguity in your indications, and may be that's the reason: does the 'share' subdirectory of web2c have to be mixed with the 'share' subdirectory of xindy-w32 ? Each one has a texmf-dist subsubdirectory. For the moment the directories structure I have is as follows : W32tex\web2c\share\texmfdist (and others) \xindy\share\texmfdist (and no other) Do you have something of the kind?
    – Bernard
    Jul 19 '13 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.