11

This is the first and probably the last time I'll ever send a paper to an Elsevier journal. I'm having a problem with the siunitx package, a package that I'm very fond of and I use it very often. The problem is that EES has TeXLive2009 and the latest versions of the siunitx package has commands that are not compatible with the package that was bundled into TeXLive2009.

I had a chat with Elsevier support about this issue and they offered no alternative, nor fix. What do you people recommend? Should I start retyping manually all measuring units that I've used so far (with standard LaTeX commands)? Is there a quick way to do it (some nice tool/script)?

Thanks.

  • 2
    You could bundle the newer siunitx version with your submission. A bit annoying, but saves you editing the document. – Tomek Jul 16 '13 at 12:12
  • I actually tried that. I uploaded the siunitx.sty and 3 more .cfg files from the package together with my submission. EES crashed or something. It didn't even get to compilation (no log file). I'll try again and post the error here. – remus Jul 16 '13 at 12:17
  • Newer siunitx depends on a lot of packages that has been updated quite a lot since TL09. – daleif Jul 16 '13 at 12:18
4

A dirty fix is to emulate siunitx commands in the preamble. It saves some time but I hope I'll never have to do it again. Are all journals so LaTeX unfriendly as Elsevier journals? Hope not.

% Measuring units commands
\newcommand{\SI}[2]{\ensuremath{#1\hspace{1pt}\text{#2}}}
\newcommand{\SIrange}[3]{\ensuremath{#1\hspace{1pt}\text{#3 to }#2\hspace{1pt}\text{#3}}}
\newcommand{\numrange}[2]{\ensuremath{#1} to \ensuremath{#2}}
\newcommand{\si}[1]{#1}
\newcommand{\per}[1]{\ensuremath{\hspace{1pt}\text{#1}^{-1}}}
\newcommand{\squared}[1]{\ensuremath{\hspace{1pt}\text{#1}^{2}}}
\newcommand{\cubic}[1]{\ensuremath{\hspace{1pt}\text{#1}^{3}}}
\newcommand{\percubic}[1]{\ensuremath{\hspace{1pt}\text{#1}^{-3}}}
\def\tonne{t}
\def\hour{h}
\def\kilogram{kg}
\def\minute{min}
\def\second{s}
\def\gram{g}
\def\mole{mol}
\def\liter{L}
\def\meter{m}
\def\metre{m}
\def\kelvin{K}
\def\cm{cm}
\def\joule{J}
\def\percent{\%}
\def\celsius{$^\circ$\hspace{1pt}C}
  • Remus, perhaps a silly question regarding your dirty fix. I receive 'undefined control sequence' erros when I paste your code in the preamble (while removing siunitx of course). Is there something obvious I'm missing? Any suggestions are welcome. – Steve Crittenden Oct 21 '13 at 8:08
  • I only defined the measuring units that I used in my document. You might use more and/or others which would need a similar definition in the preamble. – remus Oct 21 '13 at 8:26
  • If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – Claudio Fiandrino Oct 21 '13 at 8:27
  • In fact, I see that these commands are the problem: \si{153}{\per\squared\meter}. I have many of these exponents (i.e., per kilogram, per hectare per year, etc ...) – Steve Crittenden Oct 21 '13 at 8:37
2

There are two ways to resolve this: (1) Build a PDF and zip your source files. Upload both the PDF and the ZIP file as indicated here. (2) Upload your source file -- the TeX Live installation has recently been upgraded and using the siunitx package worked for me.

Retyping your source files to pass EES is generally not a good idea.

  • Good to hear they finally upgraded! Does biblatex also work? – remus Aug 12 '15 at 10:01
  • Just the bibtex backend. Since EES is nearing the end of its life, I don't expect the biber backend will become available. – Sweitse Aug 12 '15 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.