2

In a presentation created with the beamer class, I'm using

\usepackage[style=verbose,backend=bibtex]{biblatex}

and

\footcite{source}

style=verbose is required so that author, title and so on show up in the foot note and not just a number indicating the source.

However, on one slide a give an overview of different algorithms, which requires a lot of citations. Only for this slide I'd like to use \cite, which should give me e.g. [1] in the text, but no footnote. The problem is that thanks to style=verbose, \cite inserts author, title and so on instead of a short number.

How can I fix this?

  • If you change to style=numeric-comp and use \fullfootcite on all slides you want the verbose output you can use \cite on your overview slide. – Martin - マーチン Jul 16 '13 at 14:35
  • I can't get fullfootciteto work. Do I need an additional import? – mort Jul 16 '13 at 14:45
  • This may be because of my typo. Try \footfullcite instead. Sorry. – Martin - マーチン Jul 16 '13 at 14:51
  • Works! You should post this as an answer. – mort Jul 16 '13 at 14:57
2

Just change your implementation of biblatex to

\usepackage[style=numeric-comp,backend=bibtex]{biblatex}

Then you can cite on the overview slide with

\cite{<key>}

or

\autocite{<key>}

if you want to specify style commands as options in the preamble, e.g.

\usepackage[style=numeric-comp,
            autocite=superscript, % apply options here
            backend=bibtex]{biblatex}

And when a full citation is necessary you can cite with

\footfullcite{<key>}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.