I'm trying to put a .pdf graphic in my LaTeX file. This is usually no problem for me. I use pdfLaTeX in TeXworks. The only difference this time seems to be that I'm using the style files from the journal Statistical Science (http://www.e-publications.org/ims/support/sts-instructions.html).

I've tried several solutions. This one and converting the pdf to .eps or .ps all make the error go away, but then there is just a big blank space where the image is supposed to be. Any ideas?

Edit: Here is the preamble:

\documentclass[dvips,sts]{imsart}
\usepackage{graphicx}
\usepackage{float}
\begin{document}
\begin{figure}[h!]
\centering
\includegraphics[width =  \textwidth]{simLinkError.pdf}
\caption{Blah}  
\label{fig:sim1}
\end{figure}
\end{document}
  • 4
    "Cannot determine size of graphic #1 (no Bounding Box)" error occour when we compile latex on a TeX file with non-eps images such as PDF/JPG/PNG etc. To fix this error: You need to run pdflatex on the TeX file. Otherwise you need to convert your image to EPS using convert and run latex on the TeX file. – Jagath Jul 17 '13 at 3:49
  • @JagathAR, as I mentioned, I am using pdfLaTeX on my TeX file. Is this different than pdflatex? – zkurtz Jul 17 '13 at 13:11
  • @dustin, no, [demo] is not there ... – zkurtz Jul 17 '13 at 13:12
  • 1
    Can you post a small example of your problem which has the preamble? – dustin Jul 17 '13 at 13:16
  • 4
    Remove the dvips option to the class. This is all is needed. – egreg Jul 17 '13 at 13:58
up vote 19 down vote accepted

Options to \documentclass are examined by all packages. So you're loading graphicx with the dvips option, which allows only EPS graphics to be imported and is nonsense when the engine is pdflatex. So remove it.

\documentclass[sts]{imsart}

In general dvips, pdftex or xetex should not be used even with packages that know them, such as

  • graphicx
  • hyperref
  • geometry

that can deduce the needed driver by themselves.

  • Thanks again! I'd vote this up if I had enough reputation to do so. – zkurtz Jul 17 '13 at 14:17
  • 3
    @zkurtz Don't worry, you'll get it. And I really don't need more reputation, do I? ;-) – egreg Jul 17 '13 at 14:20
  • Using Texlipse under Project/Properties/Latex Project Properties output format pdf and build commands pdflatex have to be used instead of the corresponding dvi parameters. – Torsten May 8 '14 at 13:46
gs -o /dev/null -sDEVICE=bbox Input.pdf

yields

%%BoundingBox: 0 0 702 399
\includegraphics[bb=0 0 702 399]{Input.pdf}
  • Please state in which sense this posting is an answer to the original query. E.g., do state how the OP might use the information you've provided to help solve his/her issues. – Mico Oct 14 '14 at 19:45
  • Welcome to TeX.SX! I'm not sure this is an answer to the question. – egreg Oct 14 '14 at 20:15
  • It helped me. I could not change teh documentclass command, so this workaround worked. – piffy Sep 4 '16 at 17:40

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.