5

I am having a real issue with compiling BibTeX (has previously worked fine).

When I compile LaTeX, an aux file is created.

Here is my test.aux

\relax 
\citation{carron2013big}
\bibdata{rhian}
\bibstyle{plain}

I then run BibTeX on my test.tex and receive the message BibTeX finished successfully. Run LaTeX again to get citations right

But no .bbl file is generated which means non of my citations work.

Here is my test.tex

\documentclass{article}
\begin{document}
I really like the paper by \cite{carron2013big}. Its nice. 
\bibliography{rhian.bib}
\bibliographystyle{plain}
\end{document}

And my rhian.bib

@misc{carron2013big,
title = {Compressive Sensing: The Big Picture},
author = {Carron, I.},
year = 2013,
howpublished = {\url{ https://sites.google.com/site/igorcarron2/cs#reconstruction}}
}

output from Emacs is:

 'Running BibTeX on text with bibtex $s
bibtex: Need exactly one file argument.
Try bibtex --help for more information.'

Any thoughts?

  • 5
    You need to run BibTeX on the .aux file, not the .tex file. AUCTeX should do this automatically. Try doing it from the command line first to make sure there are no other problems: bibtex myfile.aux (note: the extension is not strictly necessary, but it is wise to test this first given the nature of the problem). – jon Jul 17 '13 at 18:27
  • 1
    Also the 'Running BibTeX on text with bibtex $s seems odd. Not %s? – jon Jul 17 '13 at 18:35
  • 1
    Maybe try and take this line out: howpublished = {\url{ sites.google.com/site/igorcarron2/cs#reconstruction}} . However the other suggestions seem more important. – option_select Jul 17 '13 at 22:02
  • @jon I used the terminal to run bibtex myfile.aux and the .bbl file was created and therefore I was able to create my document. I assume that my AUCTeX settings are wrong then? I usually compile by repeatedly using C-c C-c – trianglegirl Jul 18 '13 at 11:43
  • 2
    Yes, I think they are. (Although the minimal example you gave won't work without loading a package like url or hyperref. I'd also fix the spurious extra space in the howpublished field.) Have you done anything to your .emacs file? If you have, look to see if there is something like ("BibTeX" "bibtex $s" TeX-run-BibTeX nil t :help "Run BibTeX"). Note the $s: that should be %s. I can't imagine how that got mixed up unless you copied and pasted from somewhere which had a typo. – jon Jul 18 '13 at 14:28
4

(Based on discussion in the comments.)

For whatever reason, a typo seems to have creeped into the settings of the .emacs file. The error

'Running BibTeX on text with bibtex $s

was the clue. The normal AUCTeX setting should be something like bibtex %s (not $s). Making the appropriate change in your .emacs file should do the trick. Search for something like

("BibTeX" "bibtex $s" TeX-run-BibTeX nil t :help "Run BibTeX")

and make the appropriate change.

2

I had the same problem with you, and I fixed by doing so:

  1. in preamble

    \usepackage{cite}
    
  2. in document

    \bibliographystyle{unsrt} % choose a display style  
    \bibliography{rihan} % without '.bib', make sure they are in the same path
    
  3. command C-c TAB helps to invoke the bibtex file, then compile tex file twice

    C-c C-c
    C-c TAB
    C-c C-c
    C-c C-c
    

see bibtex and TeX emacs command

Hope this can help you!

0

I was struggling with this specific issue several days. I found it at last: some LaTex compilers doesn't have default defined bibliography style. So user should specify the style be using command

\bibliographystyle{STYLE-FILE}

\bibliography{biblioFILE}

and replace STYLE-FILE with the desired style file with extension .bst for example if you download the ASME author templates you will see that these commands in the TeX file asme2e.tex:

\bibliographystyle{asmems4}

\bibliography{asme2e}

So if you look at the folder you will see the style file: asmems4.bst and also bibliography file: asme2e.bib.

The reason my compiler doesn't make .bbl file because I just mistakenly cleared the style line because they are not written close to each other. So you may do the same mistake of mine! then the poor compiler couldn't make the .bbl file! :D I was in time pressure of submitting the paper and I just created the .bbl file myself!!! But after the releasing from the stress I found this simple solution!!! All problems have more simpler solution that our complicated brain thinks! This was another important lesson of life today for me. Enjoy :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.