11

Any obvious reason some of the frame is missing here:

enter image description here

\documentclass{article}

\usepackage{color}
\usepackage{hyperref}
\usepackage{mdframed}
\begin{document}

\begin{mdframed}
\begin{enumerate}
   \item Create the cumulative sum of probabilities for each care type, thus defining the interval width
   \item \textcolor{blue}{for} jj=1:m \textcolor{gray}{\% where m is the number of nurses}
   \item Choose care type
   \item \hspace{3cm}Randomly select care length ($n$) based on care type
     \item \item \textcolor{blue}{for} ii=1:n  \textcolor{gray}{\% where n is the sequence length}
   \item\hspace{3cm}Generate a random number $w$
  \item \hspace{3cm}Check into which cumulative probability interval $w$ falls and choose the corresponding surface category
  \item update ii=ii+1
  \item update jj=i+1
  \item \textcolor{blue}{end}
  \item \textcolor{blue}{end}
\end{enumerate}%}
\end{mdframed}

\end{document}
  • 1
    I correctly see the whole frame. I had to adjust your mwe as it does not compile: load xcolor rather than color. – Claudio Fiandrino Jul 18 '13 at 10:47
  • Interesting... it appears that as I zoom in some lines appear and disappear using pdflatex. Do you think this will print properly? – HCAI Jul 18 '13 at 10:52
  • 1
    I've found that behavior you note about lines disappearing during graphical rendering. I've always seen it print. However, I have on occasion noted that the contrast associated with line thicknesses "on screen" and "on paper" may differ. – Steven B. Segletes Jul 18 '13 at 11:12
  • @HCAI the appear/disappear thing sounds like you are using Adobe reader. if this is the case, try unset the "Enhance thin lines" option in the "Page Display" category of the Preferences. – ArTourter Jul 18 '13 at 11:23
  • Oh I see, hmm ok I'll trust that it works then. Perhaps I'll give it a test run – HCAI Jul 18 '13 at 12:13
13

Analysis

If package color is loaded a white background is drawn. The default framemethod uses the following z-order similar to \fcolorbox:

  1. left line
  2. top line
  3. background
  4. bottom line
  5. right line

Screens have usually a low resolution, thin lines can then have a line width of one pixel only. In the direct neighborhood the white background is drawn. Then it can happen that the white background also colors the pixels of the formerly black line, a part of the black line might contain to the background area (low resolution!, rounding issues, ...).

Printers are using higher resolutions, e.g. 600 dpi. Then a line with thickness of 0.4pt (default value). That are 3.3 pixels, when printed. Then the line will not vanish, if the thickness is one pixel short.

Test file

Test file for playing and analyzing:

  • It makes a simple page with a frame. Fonts are not needed to keep the PDF file small.
  • The page layout is simplified via package geometry.
  • Unit is bp, the default unit for PDF (and PS). This makes it easier to understand and interpret the numbers found in the page description of the PDF file.
  • PDF compressions are disabled (pdflatex). Then the PDF file can be easily inspected in a text viewer or editor.
\pdfobjcompresslevel=0
\pdfcompresslevel=0

\documentclass{article}
\usepackage[
  margin=0pt,
  hmargin=10bp,
  paperwidth=100bp,
  paperheight=50bp,
]{geometry}
\setlength{\topskip}{0bp}
\pagestyle{empty}

\usepackage{xcolor}
\usepackage{mdframed}

\mdfsetup{
  linewidth=.2bp,
  innerleftmargin=0bp,
  innerrightmargin=0bp,
  innertopmargin=0bp,
  innerbottommargin=0bp,
}

\begin{document}
\vspace*{10bp}
\begin{mdframed}
\rule{0pt}{10bp}
\end{mdframed}
\end{document}

Workaround

Package mdframed provides other framemethods. With

\usepackage[framemethod=tikz]{mdframed}

the frame is drawn after the background and therefore remains visible.

  • 2
    Also fixes a problem where the top of the frame isn't drawn at all. +1! – HarryCBurn Jan 4 '15 at 0:52
1

Rather than using mdframed try using

\usepackage{framed}

\begin{framed}
\begin{equation} 
a+b 
\end{equation}
\end{framed}
0

I tried the previous suggestion and it had no effect on my case. However, what did improve the output was to specify a different border size for the frame. Use the linewidth attribute:

\documentclass{article}
\usepackage{mdframed}

\begin{document}
    \mdfsetup{
        linewidth=0.6pt
    }

    \begin{mdframed}
        Hi there!
    \end{mdframed}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.