My Adobe decided it should be version X now, and it misbehaves in so many ways. One way is that it is impossible to get it to open a pdf document from within TexnicCenter (or I missed something...) Pressing F5 opens up the Adobe with some start menu asking me to open a recent file blablabla. But not the file I want to see. And TexnicCenter tells me the command could not be executed.

I've had it with Adobe bloatware, so I want to shift to something else. Nitro comes to mind, as I find it a decent PDF reader and editor. So I wondered if anybody had experience setting up TexnicCenter with Nitro, as I couldn't really find anything on the net. Or is there another one that is better (Sumatra is mentioned as it gives pdfsync, but again, I have no experience in this)

Thank you for your answers.


After some more searching around, I found that there is apparently a problem with the server name for Adobe ( see this discussion ). Still, I've had it with those censored. more censored. So any help on linking TC with either Nitro or something else is greatly appreciated

5 Answers 5


This This would be my TXC output profile for working with Sumatra. It allows forward and backward search and you can keep the pdf-file open while compiling. The commands are: (Check if your paths are right)


C:\Programme\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Programme\TeXnicCenter\TEXCNTR.EXE\" /ddecmd \"[goto('%f','%l')]'\""







You can also find tutorials for using TXC with Sumatra at TeXnicCenter Tutorials.

  • Thx for the answer. Tried it out and it works like a charm.
    – Joris Meys
    Mar 3, 2011 at 9:49
  • 2
    A not-related tip: If you want to take a screenshot just of the current (not maximized) window, you can press Alt+Print/Druck. Spares you the cropping work and looks nicer :)
    – doncherry
    Apr 28, 2011 at 10:05
  • @doncherry: Thanks, I was always to lazy to search for this combination :)
    – meep.meep
    Apr 28, 2011 at 10:12
  • For me this is working well, thank you, but ONE thing still annoys me: The viewer sumatra doesn't popup to the front (foreground), so I always have to select it. And about the inverse search: Is that normal that by double clicking the cursor does NOT automatically skip to the double-clicked word but only to the paragraph/sentence/item??
    – tim
    Nov 8, 2013 at 13:56

I recommend using sumatra pdf instead

It is recommended to use the -reuse-instance in the calling line to be configured inside texniccenter.

You may also want to take a look at the latest texmaker, as it comes with its on PDF viewer.

  • thx for the tip on the -reuse instance. For now I keep with TC, as I have all my projects at work in here, and the TC project files are not portable afaik.
    – Joris Meys
    Mar 3, 2011 at 9:56

I want to mention that by installing SumatraPDF first and then TeXnicCenter, the steps form the tutorial are automized.

It takes you something like 5 minutes to get a fresh installation of MiKTeX, SumatraPDF and TeXnicCenter, while getting inverse-search etc.

  1. Install latest MiKTeX (I suggest picking "Install packages on the fly: YES")
  2. Install latest SumatraPDF
  3. Install latest TeXnicCenter (Don't forget to pick your language if something else than English)

Don't forget to choose "LaTeX=>PDF".



This is not an answer to your question but for anybody who wants to continue using Adobe solutions are discussed at this question

However, most PDF readers (including Adobe) can be used by changing from DDE Command to Command Line argument and using “%bm.pdf” with a leading space in the box. That’s for View project’s output and for Forward Search.

For many readers you have to use Do not close in the last option which means you have to close the pdf manually before recompiling. However, for viewers such as PDF-XChange Viewer you can put /close “%bm.pdf” in the bottom box and the document will automatically close.

  • tried it, but with Adobe X that still doesn't really make it going smoothly...
    – Joris Meys
    Mar 3, 2011 at 9:55

Actually, the answers from Martyn and Adam Nellis solved this problem. Thanks a lot, folks. I am just putting it step by step, so someone else can use it.

  1. Adobe Reader X: In Adobe Reader X, go to Edit->Preferences->General and uncheck Enable Protected Mode at startup.

  2. TeXnicCenter: Go to Build->Define Output Profiles-> choose Latex to PDF -> Viewer tab

    For View Project's Output & Forward Search:

    • Command: [DocOpen("%bm.pdf")][FileOpen("%bm.pdf")]
    • Server: AcroViewR10
    • Topic: control

    For Close document:

    • Command: [DocClose("%bm.pdf")]
    • Server: AcroViewR10
    • Topic: control

If you are using MiKTeX version 2.9 you have to use %tm instead of %bm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.