4

I want to insert every page of a PDF file so I used:

\documentclass{customized_class}
\begin{document}
\usepackage{pdfpages}
\includepdf[fitpaper,pages={-}]{filename}
\end{document}

This works fine when using any standard classes like report. Now I have to use a customized class for the document. This causes that the pages do not cover a whole page but are slightly over the edges so that I have margins to the left and to the bottom of every page. So that the option fitpaper doesn't seem to work correctly.

Link to download the class file "mpreport.cls" - You can open it with WinRAR.

There are other files as well to create that document which are less important for this question.

Is there a way to change the class just for all the pages I will include or maybe just the pre-settings of the borders or margins created by the class file?

Maybe I could also use \includegraphics? I tried it but couldn't figure out how one option will include every page of the PDF file on a new page in the document and covering the whole page as well so that the page number will be left out.

This is how it looks like after I included the "pdfpages" documentation.

First page of the "pdfpages" documentation

  • 1
    The pdfpages documentation has many options and mentions how you can manually scale your imported pages. See mirror.utexas.edu/ctan/macros/latex/contrib/pdfpages/… – Steven B. Segletes Jul 23 '13 at 12:18
  • Well I don't want to scale the imported page. I want to use the option "fitpaper" which can be found in the document you linked so they cover the whole page. – Phil Jul 23 '13 at 12:38
  • 1
    I understand you want to use fitpaper. But if no one can come up with a simple fix (and since you are using a customized class, it may be difficult to understand where the problem arises), then scaling each page may be your only workable option. – Steven B. Segletes Jul 23 '13 at 12:49
  • You should post your class file (maybe uploaded externally). By default, \includepdf creates pages with the empty pagestyle, and that's why there's no page numbering. Does your class redefine this pagestyle? – T. Verron Jul 23 '13 at 13:22
  • Ok, I added the link in the question. You can open the package with WinRAR. The name of the class file is "mpreport.cls". – Phil Jul 23 '13 at 13:41
5

Found a option which helps (offset-option):

\includepdf[page={-},offset=<offset in x>mm <offset in y>mm]{file_name}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.