6

I use the biblatex-publist style to put my publications on my CV. I'd like to do something similar for my talks. The problem is that they get printed only with the year, and I'd like the date too. Here is a MWE:

% !TEX program = xelatex
\documentclass{memoir}

\usepackage{csquotes}
\usepackage[backend=biber, bibstyle=publist]{biblatex}
\omitname[Thomas]{Hodgson}
\addbibresource{talks_mwe.bib}

\begin{document}

\section{Talks}
\begin{refsection}[talks_mwe]
\nocite{*}
\printbibliography[heading=none]
\end{refsection}

\end{document}

And some BibLaTeX records:

@misc{one,
Author = {Hodgson, Thomas},
Title = {One},
Year = {2013-01-01}}

@misc{two,
Author = {Hodgson, Thomas},
Title = {Two},
Year = {2012-01-01}}

That does what I want, but the date is in ISO format. I'd like it to be more readable and preferably in the British Day-Month-Year style.

I suppose that there are two parts to this question: (i) Is there an easy way, without altering bib latex-publist, to have the date print differently (while being sorted as it is now)? (ii) As a bonus, could it work from the 'date' field in BibLaTeX, because it seems neater to do that than to make the 'year' field something that's not a year.

2
  • 1
    There might be a workaround for this, but I would also suggest you write a feature request to Jürgen Spitzmüller, because I think you are neither the first, nor the only one with that need. For the time being, in my cv I ended up using one of the standard styles citing the abstract with inproceedings and a note. Commented Jul 23, 2013 at 13:25
  • Emailing Jürgen Spitzmüller is a good idea. I've done it.
    – twsh
    Commented Jul 23, 2013 at 21:36

1 Answer 1

8

I have just uploaded biblatex-publist 0.7 to CTAN, which addresses your request. The date formatting itself is done via biblatex, you can modify it with the biblatex option "date" (see biblatex manual).

Please note that your MWE has an error. You need to use "Date", not "Year", i.e.

@misc{one,
Author = {Hodgson, Thomas},
Title = {One},
Date = {2013-01-01}}

@misc{two,
Author = {Hodgson, Thomas},
Title = {Two},
Date = {2012-01-01}}
4
  • That's great! I'll look forward to using it. For what it's worth, the Year/Date thing was intentional. Using Date the MWE will compile with the talks sorted by year, but with no indication of the date. Putting a date in ISO format in the year field gets them to sort in the right order (which is why I did it), but it's clearly Bad Style. (A Date in ISO format will of course put its year into Year. So, when I start using your new version my bibtex records will be as you write.)
    – twsh
    Commented Jul 25, 2013 at 19:32
  • It behaved this way since biblatex-publist did only output the year field, which is either stripped from the date info in the date field or literally the year field. Since the year field is always interpreted literally, an iso date will not be resolved, but just taken and printed "as is".
    – JSpitzm
    Commented Jul 26, 2013 at 6:24
  • I git version 0.7 and everything is fine. By the way, in order to get sorting by month and day I had to define a new sorting scheme. I borrowed the one from here: tex.stackexchange.com/questions/46868/biblatex-sorting-by-date
    – twsh
    Commented Jul 26, 2013 at 12:46
  • FYI I will add some custom sorting schemes to the next version.
    – JSpitzm
    Commented Jul 27, 2013 at 7:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .