A few days ago I switched from MiKTeX to TeX Live in order to make both my Mac and Windows computer be on the same platform. I've been ripping my hair out trying to figure out why Kile suddenly decided to stop working. To be clear, the regular compile function works perfectly. But the single most alluring feature of Kile, the live preview feature, does not work.

On the "Log and Messages" screen, this is what shows up:

[LivePreview-PDFLaTeX] test.tex => test.pdf (pdflatex)
[LivePreview-PDFLaTeX] finished with exit code 1
Cannot open log file; did you run LaTeX?

This is what shows up on the "Output" screen:

*****     LivePreview-PDFLaTeX output: 
*****     cd "F:/"
*****     pdflatex -synctex=1 -interaction=nonstopmode -output-directory=C:/Users/Kevin/AppData/Roaming/.kde/share/apps/kile/livepreview/preview-p0caaa/ test.tex
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/W32TeX)
 restricted \write18 enabled.
entering extended mode
! I can't find file `test.tex'.
<*> test.tex

(Press Enter to retry, or Control-Z to exit)
Please type another input file name
! Emergency stop.
<*> test.tex

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on "C:/Users/Kevin/AppData/Roaming/.kde/share/apps/kile

So, do any of you have any idea why Kile is having problems?

closed as too broad by Speravir, Heiko Oberdiek, Gonzalo Medina, Jesse, Guido Jan 25 '14 at 6:46

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • "p0caaa/ test.tex" - you have a space there. – Martin Schröder Jul 24 '13 at 16:50
  • @MartinSchröder I did remove the space, it still doesn't work. – Kevin Dong Jul 25 '13 at 3:28
  • I'm having the same problem described above (same log message, exit code, and question about whether I ran LaTeX). In this case, I'm using Kile to run PDFLaTeX. On this very same file it worked without any errors 5 months ago. Now, it won't finish. I'm running it on an arch linux machine working in dwm. Any ideas? It must have something to do with an update. – Richard Barrett Sep 12 '13 at 23:34
  • @RichardBarrett I did finally manage to fix it by crawling by to MiKTeX. – Kevin Dong Sep 28 '13 at 2:17