2

I am trying to type some text in LyX. The text is in Word and full of glottal stops, especially the one with the UTF code "U+02C1", namely this: ˁṬL

LaTeX prints it very differently than it is in the Word file. LaTeX puts \textrevglotstop I tried ipa, tipa etc, with no success.

Do you know how to fix it?

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Additionally a minimal working example (MWE) might be helpful to diagnose your problem as this behavior depends on, for example, the font settings. – Alexander Jul 24 '13 at 13:15
  • thanks. the only issue is this: I want to typeset "ˁṬL" in latex/lyx and the reverse glottal stop is the problem. the latexcode for it produces something very different - regardless of the latex font/encoding. so i thought no MWE is necessary. – Can Jul 24 '13 at 14:09
3

Without seeing what you're doing, it's hard to tell, but LyX has a way to process files using XeTeX, so this would probably be the simplest route for you to take.

For example, the following document should compile directly using XeLaTeX.

To set LyX to use XeTeX go to Document→Settings→Fonts and choose the option Use non-TeX fonts (via XeTeX/LuaTeX).

The Gentium Plus font can be found here: Gentium Plus. Other fonts on your system may also have the correct characters. With XeTeX, you can use any font that is installed on your system.

Not every font has all the font shapes (e.g. italics) or weights (e.g. bold) that you might need, so you may need to experiment a bit with fonts that have all them. Linux Libertine O seems to, as do Charis SIL (also available from SIL at the link above) and the Brill fonts.

% !TEX TS-program = XeLaTeX

\documentclass[12pt]{article}
\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{Gentium Plus}
\begin{document}
ˁṬL 
 \end{document}

output of code

  • thanks.. that does it - except for bolds.. i am not familiar with xetex that much. i am trying to get the above word in bold, italic and roman. italic and roman work, but bold does not work. i tried many other fonts. but i have a feeling i am missing something.. thanks a lot! – Can Jul 24 '13 at 16:51
  • Gentium does not have a bold version. Other fonts with the character do, though. Try Linux Libertine O for example. – Alan Munn Jul 24 '13 at 17:53
  • Brill and Charis fonts have bold. – Joseph Jul 24 '13 at 19:27
  • Thank you very much Alan and Joseph. I have been wasting my time testing every major font to see if they have the characters in bold and italic. – Can Jul 24 '13 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.