I use MikTeX in order to compile pdf files when creating R packages. Today I found out that I run into the following error:

* checking PDF version of manual ... WARNING
LaTeX errors when creating PDF version.
This typically indicates Rd problems.
LaTeX errors found:
!pdfTeX error: pdflatex.EXE (file ts1-zi4r): Font ts1-zi4r at 540 not found
 ==> Fatal error occurred, no output PDF file produced!
* checking PDF version of manual without hyperrefs or index ... ERROR

Any suggestion on how I might be able to fix this problem?

(this is after I've updated Rd.sty in R, following the suggestion here)


  • Try if it works if you run updmap on the command line. – Ulrike Fischer Jul 24 '13 at 13:37
  • I have exactly the same problem when using \usepackage{zi4} instead of \usepackage{inconsolata} as suggested in tex.stackexchange.com/questions/119925/…, but unrelated to Rd (not using anything related to R). I don't know if I should open a separate question. – wnstnsmth Jul 24 '13 at 13:44
  • I just changed from \usepackage{zi4} to \usepackage{inconsolata} and got the error: LaTeX errors when creating PDF version. This typically indicates Rd problems. LaTeX errors found: ! LaTeX Error: File `inconsolata.sty' not found. Type X to quit or <RETURN> to proceed, or enter new name. (Default extension: sty) ! Emergency stop. <read *> l.281 – Tal Galili Jul 24 '13 at 13:51
  • @UlrikeFischer - could you please give more details? simply running updmap does not seem to do much. – Tal Galili Jul 24 '13 at 13:52
  • Run this document: \documentclass{article} \begin{document} \font\test=ts1-zi4r \test \char95 \end{document} with pdflatex. Does it work? – Ulrike Fischer Jul 24 '13 at 14:06

I ran into this issue, and after some time spent banging my head against a post, I did reach a solution. After installing the package, run the following steps from inconsolata README. Open a cmd and run:

initexmf --update-fndb
initexmf --edit-config-file updmap

The latter command should open updmap.cfg in your default editor, commonly Notepad. Add the line below, then save and close.

Map zi4.map 

Now in the command window, type

initexmf --mkmaps
  • 7
    Hallelujah I was banging my head against the wall for 3hrs with this. Came across this post and it worked. – Tyler Rinker Sep 15 '13 at 13:01
  • This worked for me. For users not so experienced: put line 1 and 2 in a windows console (cmd). Line 3 and 4 of the answer are description for you how to handle line 5. Line 6 is a description for you. Enter line 7 and you're done! – agoldev Jul 26 '17 at 13:22

In ubuntu, try to install


for me, it did the trick.


this problem is not specific to windows/MikTeX. It's caused by the engine used to compile R-help files.

In particular it will also happen if you are using ubuntu (in my case 12.04, with standard laTex install from the ubuntu reps, e.g. no PPA).

The lines above solved the problem for me.

  • 1
    The question was explicitly about MikTeX (which implies that he is using Windows, not Ubuntu). – Christian Clason Oct 22 '13 at 9:05
  • 2
    However, a related problem exists in Ubuntu, which is solved by this answer. – cbeleites Oct 29 '14 at 21:43

R 3.0.2 is normally completely compliant with the latest version of inconsolata (July 2013 or later), so if you still have problems, start with updating your TEX installation, your R installation and your TEX packages.

On a Windows machine with a MIKTEX installation, try the following steps :

  • update R to at least R3.0.2 (that one is adapted for the new inconsolata package)
  • update your MIKTEX installation to the latest version
  • Run the update manager to make sure you have the latest version of inconsolata installed

  • If you use a different account for administrator and user, check if you don't have the inconsolata package installed twice (once as administrator, once as user). If so, either delete one of both installations, or make sure both versions are updated to the latest.

I had an old version of inconsolata floating around in my user installation, which kept me busy for a couple of hours. This post of Duncan Murdoch led me to the solution.

If all the above is OK, it should work without having to update Rd.sty or installing extra fonts on all main OS's.


I got the same error when I installed R, Rtools and MiKTeX in a Windows 8 machine. I followed the suggestions made in https://stat.ethz.ch/pipermail/r-devel/2013-June/066850.html, and installed the patched version of R-3.0.1. However the problem remained with the same message error.

The solution for me was just to uninstal the inconsolata package in the MiKTeX Package Manager, and then run the command R CMD Rd2pdf --pdf mypackage again, and it worked for me!

Best, Tonio

  • That is because you probably had 2 versions of the inconsolata package installed (see my answer) – Joris Meys Feb 21 '14 at 10:43

protected by Community Oct 22 '13 at 11:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.