3

I want to change the bibliography to german. I tried to do this by adding the package \usepackage{bibgerm} and changed the \bibliographystyle{gerplain}. But when I change these two things I get the Error:

"! Package babel Error: You haven't defined the language German yet"

Without these changes everything in the document works just fine. Can someone help me?

\documentclass[a4paper,      % DinA4
headsepline,                 % Strich unter Kopfzeile
footsepline]{scrreprt}       % Strich über Fußzeile
\usepackage[utf8]{inputenc}  % für Umlaute
\usepackage[ngerman]{babel}  % für Silbentrennung
\usepackage{bibgerm}

\begin{document}
Test, Test \cite{Fertigungstechnik}

\bibliographystyle{gerplain}
\bibliography{literaturverzeichnis}
\end{document}
2
  • 1
    Welcome to TeX-SX! Have a look at our starter page for a quick intro if you wish to familiarize yourself with our format. Commented Jul 28, 2013 at 17:47
  • For those who are directed here by a search engine: The package bibgerm is now superseeded by babelbib Commented May 14, 2021 at 14:00

1 Answer 1

5

You very likely switched from the german to the ngerman option with babel. In that case, deleting all auxiliary files before compiling helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .