3

I have a problem with inserting PDFs into my lyx document. I (perhaps stupidly) have made my figures all into one page each (created using powerpoint, then PDFing them), then inserted them using PDFPages into my Lyx document. I had tried inserting them using floats, but it seems to struggle with full-page figures (maybe I am doing something wrong there?). I can't use Lyx's figure-maker option really as I have a lot of landscape figures and it has already taken me ages to get each figure to fit on one page and look nice (and I have spent ages positioning the figure legend in the PDF so that it looks pretty).

The problem I have is that there is no page numbering on these inserted figures. Lyx counts them as pages (i.e. if the page before is 6, then the page after my figure is 8), so it obviously does recognise that there is a page there. But I need kinda my figures to have page numbers. I guess that I could do it manually (ugh go back to the powerpoint, put numbers in, then re-insert all 60+ figures). But if I have corrections for my thesis I'll have to do that all over again :'(

This probably stems from my foolishness of trying to avoid the lyx figure system, but any help at all would be much, much appreciated.

(additional info, I don't know if this is useful? Document class=article, :

\bibliographystyle{unsrt}
\usepackage{url}  
\pagenumbering{roman}
\let\myTOC\tableofcontents
\renewcommand\tableofcontents{%
\myTOC
\clearpage
\pagenumbering{arabic}
}

[I used this lovely site to get round the arabic numbering problem for the table of contents]

3

You can find (most of) the answer in How to add a page number to the included PDF pages?

When using using PDFpages to include external PDFs in a LyX document, LyX adds the following LaTeX code:

\includepdf{filename}

To add pagenumbers at the bottom of each page, this has to be changed to e.g.

\includepdf[pagecommand={\thispagestyle{plain}}]{filename}

In LyX, this optional argument (what is in the brackets) is added via the settings for the included material. This is the second tab in the window that pops up when you do Insert --> File --> External material, LaTeX and LyX options. In the option field, add e.g. pagecommand={\thispagestyle{plain}}. For figures you've added already, right click them and choose Settings.

screenshot of LyX external material settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.