11

I've used the command \AtEveryBibitem{\clearfield{month}} to prevent biblatex from printing the month of publication in the bibliography. This has worked fine at least until biblatex version 2.5 and biber version 1.5:

\documentclass{article}
\usepackage[style=authoryear]{biblatex}
\AtEveryBibitem{\clearfield{month}}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@ARTICLE{lennon,
    AUTHOR = "John Lennon",
    TITLE = "I wrote great music",
    JOURNALTITLE = "Journal of Music",
    YEAR = "1978",
    MONTH = "10",
    PAGES = "15--27",
    VOLUME = "5"}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\nocite{lennon}
\printbibliography
\end{document}

enter image description here

In biblatex version 2.7a and biber version 1.7, however, this command apparently has no effect anymore:

enter image description here

What do I need to do in the new version of biblatex to prevent printing the month of publication?

  • I don't know whether it is a bug or something new, anyway the workaround in this answer works for me. – karlkoeller Jul 30 '13 at 14:58
  • The year part of authoryear labels incorporate dates as of biblatex 2.6. So if you want to ignore months and days everywhere (including sorting), you need to omit these from the source (as in the post karlkoeller links to). – Audrey Jul 30 '13 at 16:10
  • 1
    Given the number of questions asked earlier on TeX.sX on how to prevent biblatex from printing months in the bibliography, it's reasonable to assume that this would be a desired feature. It would be useful if someone could spell out in plain words and provide a command for how to do that. The answer to the question karlkoeller links to includes things like datatype=bibtex, which seems tailored to the OP's request, and not a general solution for how to suppress months in the bibliography. – Sverre Jul 30 '13 at 16:33
  • @Sverre Your source file in the example uses the BibTeX format, so the post applies to your problem as well - (again) assuming you want to ignore days and months everywhere including sorting. The \clearfield approach is still relevant to all styles that don't use date labels. – Audrey Jul 30 '13 at 16:48
  • 1
    @Sverre AFAIK yes. PLK would be a better person to ask about the datatype option. Citation labels are constructed by the backend, so your have to delete the field at the source. I can totally see how all this is unclear, so I've suggested year-only labels here: github.com/plk/biblatex/issues/148 – Audrey Jul 30 '13 at 17:05
13

Actually, the field you should clear is labelmonth, not month. If you change the command to \clearfield{labelmonth}, it works. To fully clear months, you should clear both labelmonth and month. This is because authoryear styles use labeldate=true and therefore the label* fields are used as the sources for the various date fields.

labelmonth and labelday were added in 2.6 in order to mirror labelyear which is why you see the difference to 2.5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.