11

I recently installed Mepis on my computer, so I had to install LiveTex, TeXmaker, etc. from scratch. Everything works fine in TeXmaker, except for the .pdf. Every time I compile and want to see the .pdf, I get an old version. No messages of errors, no nothing appears, so I don't know what could it be. I tried with changing the options in Configure TeXmaker: Built-in viewer, Built-in viewer + Embed, and External viewer (Okular in my case). I closed the .pdf when I compiled, but still: the same old .pdf is there.I even tried deleting the .pdf from the directory, then run Quick built, and got an error (No file found).

Any ideas?

  • What does quick build do, exactly? What if you compile with e.g. pdflatex instead (shortcut F6) and then view the PDF (F7)? – Torbjørn T. Jul 31 '13 at 7:41
  • Quick build is a shortcut for PDFLatex + View PDF. I also tried doing it separately, as you say, but it didn't result. – Nalerive Jul 31 '13 at 7:47
  • What happens when you run pdflatex? – Torbjørn T. Jul 31 '13 at 8:02
  • nothing, I get the same old pdf and no message of error or something remotely similar. It simply doesn't work (and I cannot figure it why) – Nalerive Jul 31 '13 at 8:05
  • 1
    let us continue this discussion in chat – Torbjørn T. Jul 31 '13 at 8:33
4

I've had the same cryptic problem twice before where new documents won't compile and TexMaker throws no errors and just loads the previous successfully compiled pdf.

As the OP's answer suggests, this is an issue with TexMaker not having access to the proper latex packages. I had the same issue on windows, I resolved it by installing MikTeX which loaded all the necessary latex packages on my system, then reinstalling TexMaker again.

I believe I got the original error because I installed TexMaker before I had any latex packages installed on my machine.

  • Fair enough that this could be a comment, but I believe this does answer the question with a solution which is unique from the other posted answers. The OP's posted result is Linux specific, while the question has no tags regarding the OS. This is a windows specific answer which resolves the problem described by the OP. – RTbecard Jun 21 '16 at 12:02
  • it works pretty fine! – Francisco Maerle Nov 3 '16 at 19:39
2

Problem solved. I downloaded some packages (texlive-latex-recomended/extra, texlive-humanities and others) and everything is working perfect now. Thanks Torbjørn T. for your time!

  • 4
    You just added the packages? what exactly? I have the same problem. Thanks. – Hiperion Oct 1 '13 at 1:46
  • 2
    I added the mentioned packages by adding "\usepackage{}" command but the pdf file is still the same. Can you please mention if you did anything in addition to that? Im using TexMaker on Windows 8. Thank you, Negin – user54390 Jun 11 '14 at 16:55
1

In Texmaker, the "--output-directory=build" parameter is only supported by the latex and pdflatex commands and not by bibtex. This is a known issue in Texmaker. Inorder to solve this, either

  1. Disable "Build subdirectory" option in Texmaker, under Options -> Configure Texmaker -> Commands, Uncheck "Use a Build Sub-Directory for output files" and try Quick build again.

                                           (or)
    
  2. Replace "%" by "build/%". (Refer http://www.xm1math.net/texmaker/doc.html#SECTION42)

      dvips -o build/%.ps build/%.dvi
      ps2pdf build/%.ps build/%.pdf
      bibtex build/%.aux
    
  • I've updated the answer. – BEFL Jul 28 '14 at 17:46
  • didnt work here – Francisco Maerle Nov 3 '16 at 19:10
0

I had the same issue, resolved by running Texmaker as administrator.

  • and how can you do that? – Francisco Maerle Nov 3 '16 at 19:09
  • On windows, right click on TexMaker Icon then clic on run as administrator, on Ubuntu, the famous "sudo" – Bensmaine Abderrahmane Dec 6 '16 at 20:13
0

I used the solution mentioned in a comment on texmaker overwrites file that was externally modified , which states to go to Options in Texmaker, then click the Editor-tab and then hit 'Check for external changes'. Worked for me!

0

My problem was the same as described above. I run Texmaker 4.5 on macOS Mojave. I have a very important thing to do, that why I was afraid of making an upgrade.

I tried different things. Name or location changes, description, label...

Until I opened the file in PDF Expert and save it as Flatten. I think it's a really quick solution if you have the same tools. Perhaps combining with Preview.app would also be effective.

  • @bmv I don't understand. I've got the same problem and I described my solution to this. Nalerive asks: Any idead? Perhaps it will be useful to someone like me who will find this tread in the future. – Piotr Gogolin Mar 18 at 13:27

protected by Community Apr 23 at 13:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.