8

I have been using the biblatex-chicago package in my essay to generate footnotes for citations using \autocite and \autocites... but now I wish to have endnotes rather than footnotes. I first load the biblatex-chicago package as follows:

\usepackage[backend=biber,notes,natbib,isbn=false]{biblatex-chicago}  

I have tried a variety of creative methods to then use endnotes, including:

\usepackage{endnotes}
\let\footnote=\endnote
%begin page
%content here, include references like \autocite[191]{LetHistoryJudge}
%end of content
\theendnotes

This successfully includes "Notes" at the end, but it doesn't translate the bib reference into the actual citations. I get "LaTeX Warning: Citation 'LetHistoryJudge' on page 7 undefined on input line 29." and similar warnings for all of my citations. These citations, I might add, work perfectly fine as footnotes when I remove the endnotes package and don't redefine the endnote command as the footnote command. What's the proper way to do this? I haven't found an option in the biblatex-chicago package itself that would allow me to set endnotes instead of footnotes.

Thank you in advance for any help!

  • 2
    instead of \let\footnote=\endnote I'd use biblatex's notetype=endonly option. This doesn't get rid of the warnings, though, although the output looks right... – clemens Jul 31 '13 at 21:08
  • Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. Also, do yourself a favour and change your username to something more telling than "user1607754" :) – Xavier Jul 31 '13 at 21:09
  • loading endnotes after biblatex-chicago works for me – henrique Jul 31 '13 at 21:11
  • @henrique really? I get LaTeX Warning: There were undefined references. either way – clemens Jul 31 '13 at 21:20
  • 1
    I think the various cite commands from biblatex are too clever and something is getting lost in the writing to the .ent file; this is easy to check if you redefine \autocite this way: \renewcommand{\autocite}[1]{\footnote{\cite{#1}}} and look at the new .ent file. One simple solution would be to \nocite everything you actually cite; unfortunately, it is tricky to prepend a \nocite{<key>} to every \smartcite{<key>} through simple redefinitions because of the way the \DeclareCiteCommands work (unless you never use any optional arguments in your \autocite commands). – jon Aug 1 '13 at 7:06
3

I know this type of problem, and have identified a few issues myself:

  • Make sure you have installed all the packages of biblatex-chicago as per the documentation
  • Update your package repository to the latest
  • Make sure you refresh your FNDB and Update Formats (from settings menu in MiKteX)
  • I used winedit 8, and biber, so I needed to get an extra plugin called lateXify, which compiles, does the cross referencing, compiles again, etc...

Winedit is not free, but the trial version is pretty functional and it's not expensive.

I needed to install latex on another computer, and had to go through all the pain again, and realised, following the steps above, correctly, got me where I wanted.

Hope that helps you.

0

@jon's comment helped. It's important to remember the \theendnotes command at the end of your document.

\usepackage[notes,notetype=endonly,isbn=false,doi=false,url=false,backend=biber]{biblatex-chicago}
\usepackage{endnotes,setspace}
\let\footnote=\endnote
\let\cite=\autocite
\renewcommand{\autocite}[1]{\footnote{\cite{#1}}}
\begin{document}
Hello.\cite{tom1999}
\clearpage
\theendnotes
\printbibliography
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.