2

I have followed the install instructions for texlive for unix, and have set the path permanently - i.e. "echo $PATH" gives the following output -

/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/jtait/.script:/usr/local/texlive/2013/bin/x86_64-linux

(the correct texlive directory being at the end). Also, tlmgr is working fine, so it certainly is the right path.

However, when I run pdflatex everything it loads is in /user/share, and it using this version:

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/Debian)

If I remove tex-live (which I thought I had - I since purged it), it still won't work.

Is there something other than setting the path that I should be doing? I don't know if this is pdflatex specific.

I am on an Ubuntu install, 13.04.

This question on the Ubuntu stack exchange appears to be related (though with no answers).

I left all the install options as default, in case that is relevant.

  • Check which pdflatex is the one used with which pdflatex? Have you checked that the path to your manual texlive install is correct? – Markus Aug 1 '13 at 14:57
5

The $PATH environment uses whatever is defined first as the command. Eg. : PATH=<dir1>:<dir2> If the command appears in both directories, the <dir1> will still be the one used. Try moving the texlive bin directory to the beginning of the $PATH environment.

  • That's great, thank you very much for the help. – Joe Tait Aug 1 '13 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.