I have TeX Live installed on my MacBook Pro running MacOSX 10.8 through macports. Recently on trying to compile a LaTeX file through pdflatex I got the error

! I can't find file `dehypht-x-2012-05-30.tex'.
<to be read again> 
l.180   \repeat

(Press Enter to retry, or Control-D to exit)
Please type another input file name: 
! Emergency stop.
<to be read ' instead of a filename.
I can't find the format file `pdflatex.fmt'!

After some googling I figured that maybe sudo fmtutil-sys --all might fix that but it ends in the following error:

This is a summary of all `failed' messages:
`pdftex -ini  -jobname=pdftex -progname=pdftex -translate-file=cp227.tcx *pdfetex.ini' failed
`pdftex -ini  -jobname=etex -progname=etex -translate-file=cp227.tcx *etex.ini' failed
`pdftex -ini  -jobname=pdfetex -progname=pdfetex -translate-file=cp227.tcx *pdfetex.ini' failed
`pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini' failed
`pdftex -ini  -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini' failed
`xetex -ini  -jobname=xetex -progname=xetex -etex xetex.ini' failed
`xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed

Any clues as to what I could do here?

farhat$ pdflatex --version
pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013/MacPorts 2013_1)
kpathsea version 6.1.1
Copyright 2013 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.5.16; using libpng 1.5.17
Compiled with zlib 1.2.8; using zlib 1.2.8
Compiled with poppler version 0.22.5
  • 2
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – texenthusiast Aug 2 '13 at 19:14
  • 3
    Well the format generation fails as a file is not found. So you either need the file or should change the language settings so that it is no longer required (in a current texlive a newer version of the file is used dehypht-x-2013-05-26.tex). But you didn't say which version of texlive you are using so it is difficult to be more precise. – Ulrike Fischer Aug 2 '13 at 19:16
  • How can I get the texlive version? tex --version gives TeX 3.1415926 (TeX Live 2013/MacPorts 2013_1) kpathsea version 6.1.1 – Farhat Aug 3 '13 at 6:09

I encountered the same issue just today (here with OS X 10.6 and MacPorts.) The solution that worked for me was to do sudo port install texlive-lang-german.

  • Somehow this worked (although my documents are not in german) – Fabian Pedregosa Aug 28 '13 at 12:19
  • My documents aren't in German either. :-) The correct solution is probably to figure out why TeX Live is looking for the German language data in the first place. There's probably a configuration default somewhere that needs overriding. – Mark Dickinson Aug 30 '13 at 15:08

When you have installed TeX, do not set the environment what the system tells you. Just this one


You # it, and re-login. It is OK!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.