6

Has anyone else noticed this kerning error in Linux Libertine small caps...?

Kerning combo "Va" (and "Wa") error in Linux Libertine.

What are the (1) permanent solution & (2) quick local fix?

Pretty important initial combo.

Here's the code:

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt]{article}

% PACKAGES

\usepackage{geometry}
\geometry{letterpaper}
\usepackage{fontspec}
\usepackage{xltxtra}
\defaultfontfeatures{Mapping=tex-text}
\setromanfont[Mapping=tex-text]{Linux Libertine O}
\setsansfont[Scale=MatchLowercase,Mapping=tex-text]{Linux Biolinum O}
\setmonofont[Scale=MatchLowercase]{Linux Libertine Mono O}

% BEGIN

\begin{document} % ==============================================================

Vacillate Vaccine Vapour Vanish Va...

\textit{Vacillate Vaccine Vapour Vanish Va...}

\textsf{Vacillate Vaccine Vapour Vanish Va...}

\texttt{Vacillate Vaccine Vapour Vanish Va...}

\textbf{Vacillate Vaccine Vapour Vanish Va...}

\vspace{3ex}

\textsc{Vacillate Waccine Vapour Vanish Va...}

\textsc{\textsf{Vacillate Vaccine Vapour Vanish Va...}}

\end{document}
  • 3
    Compiling your document with lualatex (without xltxtra) gives good kerning pairs. – henrique Aug 3 '13 at 23:21
  • 2
    Also good kerning pairs for the examples using \usepackage{libertine} and [pdf]latex. – user22108 Aug 4 '13 at 4:16
8

After discussing this on HarfBuzz mailing list, it appears to be a bug in the latest version of Linux Libertine. The proper action here is to notify the font developers and point them to that discussion, a short term “fix” is to downgrade to version 5.1.3 of the font.

Based on that, I believe it is a LuaTeX font loader bug to apply the kerning here, as it does not confirm with the OpenType specification (or its defacto reference implementation; Uniscribe).

  • I'm confused by your reference to a LuaTeX font loader bug -- the problem described by the OP occurs if the document is compiled with Xe(La)TeX; the "VA" kerning problem does not arise if the document is compiled under Lua(La)TeX. – Mico Aug 4 '13 at 12:17
  • @Mico: right. The LuaTeX issue is also a bug, since it applies kerning incorrectly (albeit with a an accidentally correct result.) – Alan Munn Aug 4 '13 at 12:22
  • 1
    @Mico: As Alan said, though applying the kerning here gives the desired result, it violates the spec and thus can potentially break other fonts that might depend on this behaviour (unlikely but not impossible). – Khaled Hosny Aug 4 '13 at 13:01
  • 1
    Reported. For the time being the bug can be avoided by using base mode. – Philipp Gesang Aug 4 '13 at 13:47
  • 1
    @commonhare: Renderer=Base option in fontspec font commands. – Khaled Hosny Aug 5 '13 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.