3

I am using the beamertemplate and I have one frame:

\frame{
\frametitle{Title text}
\begin{textblock*}{50mm}[1,1](15.9cm,9cm)
\includegraphics[width=1.9cm]{thumbnail.png}
\end{textblock*}
\vspace{-0.5cm}
\hspace{1cm}
\animategraphics[scale=0.4,autoplay]{8}{movie}{000}{200}

}

The problem is, that the animatedgraphic has white space at the top, which is covering my title text. So how can I tell LaTex, that the title text is "more important" and that the title is in front of the animatedgraphic? So that the animatedgraphic is in the background?

3
+50

Animated graphics produced with the animate package are rendered within PDF annotations (interactive regions) which live, by design of AdobeReader, in a separate layer in front of the page content.

Thus, you will have to remove the excess white space of your graphics files before embedding if you want to prevent it from obscuring the page content.

Alternatively, you can use the bb=..., viewport=... or trim=... options of the \animategraphics command. See the animate package doc. And don't forget to remove the negative \vspace.

  • Damn - I just wanted to use a animation in the background canvas of a beamer presentations which didn't work (was always in the foreground). Now I know why. – Dr. Manuel Kuehner Feb 19 '17 at 18:43
  • @manuel Try option method=ocg. However, it is slow. – AlexG Feb 19 '17 at 18:52
  • Thanks. I tried it and it works - and yes, it is (too) slow (for my use case :)). Still - the package is amazing. – Dr. Manuel Kuehner Feb 19 '17 at 20:00
  • 1
    @manuel That is because the whole PDF page content is re-rendered with every animation frame when using the ocg method, not just the annotation appearance. – AlexG Feb 19 '17 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.