1

I am having an issue with hyperref not linking the ToC to the chapters/sections. I have had a look around and I can not find a solution to my problem. If this is duplicated, my apologies...

I am writing my thesis at the moment and its due soon so I'd like this fixed.

I am currently using TexLive2013 in Ubuntu 12.04. I was previously using TexLive2009 however, I read that the caption package can cause hyperref to stop early so I updated. I am still having this issue with the folowwing error:

Package hyperref Message: Stopped early.

)

Package hyperref Message: Driver (autodetected): hpdftex.

Is this driver needed? Can I just delete it?

Either way, hyperref appears to be working fine elsewhere i.e. urls etc. I have pasted my preamble below, perhaps I have a package conflict? The update to TexLive2013 however did cause the lineno package to stop working

Any advice appreciated.

Cheers, Dave

\documentclass[12pt,a4paper,openany]{/home/dbyrne/PHD/Dropbox/MyThesis/report_custom}
\usepackage[innermargin=40mm, outermargin=20mm]{geometry}



\usepackage{array}
\usepackage{graphicx}
\usepackage{float} %for image placement
\usepackage{longtable}
\usepackage{comment}
\usepackage{color}
\usepackage{soul}
\usepackage{longtable} 
\usepackage{pdflscape}
\usepackage[authoryear, square]{natbib}
\usepackage{eurosym}
\usepackage[nohyperlinks,withpage]{acronym}
\usepackage{caption}
\usepackage{subcaption}
\usepackage[toc,page]{appendix}
% \usepackage[]{lineno} % for line numbers. Not working with Texlive2013
\usepackage{acronym}



\usepackage{draftwatermark}
\SetWatermarkLightness{0.9}
\SetWatermarkScale{5}

\usepackage[pdfpagelabels,implicit=false]{hyperref}
\hypersetup{
    linktoc=all,
    colorlinks,
    citecolor=CadetBlue,
    filecolor=CadetBlue,
    linkcolor=CadetBlue,
    urlcolor=CadetBlue
}


\renewcommand{\thefootnote}{\fnsymbol{footnote}}

\graphicspath{paths}
\linespread{1.3} %1=single, 1.3=1.5 and 1.6=double

\begin{document}

EDIT - SOLUTION

As DG pointed out below, the issue is with loading hyperref with the [implicit=false] option. Once removed, the ToC was linked. Thanks again DG.

For those wondering why I loaded [implicit=false] in the first place; I can not remember. Google probably told me at some stage..

  • 1
    The option implicit=false for hyperref is responsible for this behavior. It would be nice if you could explain, why you have set it to false, because all the packages used in your example seem to be compatible with hyperref. – DG' Aug 6 '13 at 17:45
  • There’s no need to add “SOLVED” to the title. A question is marked as solved by accepting one of the answers. – Tobi Aug 7 '13 at 11:59
1

On TL2013 I was able to successfully compile the following document with pdflatex:

\documentclass[12pt,a4paper,openany]{report} 
\usepackage[innermargin=40mm, outermargin=20mm]{geometry}

\usepackage{array}
\usepackage{graphicx}
\usepackage{float} %for image placement
\usepackage{longtable}
\usepackage{comment}
\usepackage[usenames,dvipsnames]{color}
\usepackage{soul}
\usepackage{longtable} 
\usepackage{pdflscape}
\usepackage[authoryear, square]{natbib}
\usepackage{eurosym}
\usepackage[nohyperlinks,withpage]{acronym}
\usepackage{caption}
\usepackage{subcaption}
\usepackage[toc,page]{appendix}
\usepackage{lineno} 
\usepackage{acronym}

\usepackage{kantlipsum}

\usepackage{draftwatermark}
\SetWatermarkLightness{0.9}
\SetWatermarkScale{5}

\usepackage[pdfpagelabels]{hyperref}
\hypersetup{
    linktoc=all,
    colorlinks,
    citecolor=CadetBlue,
    filecolor=CadetBlue,
    linkcolor=CadetBlue,
    urlcolor=CadetBlue;
}

\renewcommand{\thefootnote}{\fnsymbol{footnote}}

\graphicspath{paths}
\linespread{1.3} %1=single, 1.3=1.5 and 1.6=double

\begin{document}
\tableofcontents

\chapter{Principles of Reason}

\begin{linenumbers}
\kant[1-2]
\end{linenumbers}

\chapter{Things in themselves}

\begin{linenumbers}
\kant[3-4]
\end{linenumbers}

\end{document}

I encountered non of the problems you described. As I only changed three things (I used the document class report, added use names,dvipsnamesto \usepackage{color}, and deleted the option implicit=false from \usepackage{hyperref}), I do suspect that the source of your problems is either your TL installation or your custom document class.

As a first step I would try to compile your document using the class report and compare the errors.

  • Hi DG. Thanks for your efforts and help. You are correct, having the [implicit=false] is what cause the problem. I can not remember why I included this option, it was a fix to some problem I was having at some stage. – user34716 Aug 7 '13 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.