1

I have this simple piece of code here:

\documentclass[11pt]{book}
\begin{document}
\tableofcontents
\clearpage
\section{Dummy section 1}
\section{Dummy section 2}
\end{document}

And every time I add \usepackage[greek]{babel} I get the following errors at the compiler:

("C:\Program Files (x86)\MiKTeX 2.9\tex\generic\babel\lgrcmr.fd")TFM file
C:\Users\stamatis\AppData\Local\MiKTeX\2.9\fonts/tfm/public/cbgreek \grxn2488.tfm
already exists.
pdflatex.EXE: The font file could not be found.
pdflatex.EXE: Data: grxn2488
texify: pdflatex failed for some reason (see log file).

Note that without the language change I get the desired results. Do you have any idea on how to correct this?

  • 1
    I guess you have only installed basic MiKTeX? If yes, I would install complete MiKTeX. Or you use the MiKTeX package manager to install the needed packages ... BTW: Welcome to TeX.SE! – Mensch Aug 6 '13 at 18:31
  • I dont remember I installed it 1 and a half year ago but I guess I installed the basic MiKTeX.Where can I find the complete MiKTex?Thanks a lot anyway! – Stamatis Samaras Aug 6 '13 at 19:24
  • Yeah I did a little research of my own and its being installed right now.Thanks again! – Stamatis Samaras Aug 6 '13 at 19:55
  • I completed the installation of the complete MiKTeX yet nothing changed, the same error occurs if I use the language package – Stamatis Samaras Aug 6 '13 at 21:35
  • 2shared.com/file/c7JgjoVH/untitled-4.html ,here is the log file.I also have MiKTeX 2.9 and babel v3.8m.Note also that this happens only with book class,if I change it to {article} this error stops occuring – Stamatis Samaras Aug 7 '13 at 8:30
1

It seems you are using an older or incomplete version of MiKTeX 2.9.

Compare your first line in the log:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9) (preloaded format=pdflatex 2011.11.6) 7 AUG 2013 11:24 entering extended mode

with mine (no errors or warnings):

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (MiKTeX 2.9) (preloaded format=latex 2013.8.7) 7 AUG 2013 10:58

Do you see where they are not equal (see bold printed parts)?

You are using an older version of pdflatex from 2011.

So you said you installed the complete version of MiKTeX. Have you also updated afterwards the packages? Since the complete version was released there have been several changes you can install by updating your system with the update tool of MiKTeX (Windows-start -> all programms -> MiKTeX 2.9 -> Maintanace (Admin) -> update.

  • Version 3.1415926-2.5-1.40.14 (MiKTeX 2.9 64-bit) (preloaded format=pdflatex 2013.8.7) 7 AUG 2013 12:01 the updated log file – Stamatis Samaras Aug 7 '13 at 9:14
  • @StamatisSamaras Note that upvoting (clicking on the upward-pointing pen nib) is different from accepting an answer. – lockstep Aug 7 '13 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.