5

When I press the view PDF the internal viewer always jumps to the front page, with a red square indicating that I have made a change to the headline, but I have made no change. (Sometimes the red square is some random place on the front page)

Is there a way to make the internal viewer open the page which I have just viewed, I is verry frustrating that I have to scroll down to page 50 each time I press the view PDF.

My Frontpage looks like this: (I dont se any problem)

\begin{document}
\lstloadlanguages{Matlab}
\begin{titlepage}
       \begin{center}
            {\Huge The dielectric loss strength variation along an isomorph\\[1cm]
            }
       \end{center}
       \clearpage
\end{titlepage}
6
  • Two options : 1. Place a bookmark before the line number in TeXmaker and Click the Jump to the bookmark at [1] [2] [3] at top right hand side and right click at the bookmarked line press jump to pdf or ctrl+space 2. Navigate the pdf via Show/hide table of contents near line col and row no thru page number/sections Aug 6, 2013 at 19:07
  • With my old Texmaker 3.5.2 the red sqare covers always the block where my cursor in the text is located, not the current view of the sourcecode. Try placing the cursor in your source where you want to start reading your pdf. :) Aug 7, 2013 at 10:23
  • 1
    Are you sure the command line for PdfLaTeX includes -synctex=1? Please check Options -> Configure Texmaker.
    – juliohm
    Jan 4, 2014 at 14:19
  • In my experience, SyncTeX does not work when the full path to the file includes spaces. So the feature you want to use will only work on files with no space to their path.
    – marczellm
    Feb 3, 2014 at 14:00
  • Additionally, you might want to update to the most recent version of Texmaker. A lot of issues have been fixed since 4.0.3, see the changelog.
    – matth
    Feb 3, 2014 at 14:06

3 Answers 3

2

I guess it depends indeed on the place of the cursor and since I'm using one main page and use \include to add different chapters, the pdf viewer always goes to the first page where my cursor was which is quite annoying. A simple solution is to add -synctex=0 to the command line of PdfLaTex (Options -> Configure Texmaker) which will disable the jumps of the pdf viewer to a different page.

1
  • Synctex is a very useful feature, disabling it seems overkill - it would be preferrable to keep synctex and just disable "auto-jump to cursor position when you update the pdf". However, this option still does not seem exist in TeXMaker 5 years after your post :-(
    – Arnaud
    Jan 11, 2021 at 15:24
2

It is also possible to define the main document as "Master Document" under Options. Then, when you directly compile the other latex file (eg Chapters/Results.tex) the cursor jumps to where was edited in the other latex File.

Hope that helps.

1

This has most likely to do with your version of pdflatex.

Check it by opening up cmd (Windows start -> run -> cmd.exe) and type

pdflatex --version

If your version does not correspond to the version on http://miktex.org/, remove the old version of MiKTex from your computer and download and install the newest MikTex version to your computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.