5

I'm using MyriadPro. When compiling, I'm getting a lot of fontaxes warnings:

Package fontaxes Warning: I don't know how to decode (fontaxes) family `cmr' on input line 632.

I would like to suppress these. A previous question about natbib was similar, but I'm unsure how to extend that answer to this specific case.

I've found this [7.1206-7.1227 of typeface.sty], which appears to do what I'm after, but inserting the below fragment doesn't work:

   \ifdef{\fa@warn@undecodable}{
     \renewcommand*\fa@warn@undecodable[1]{}
     \TF@PackageInfoNoLine{Silenced fontaxes command %
        \string\fa@warn@undecodable}
   }{}
   \ifdef{\fontaxes@warn@undecodable}{
     \renewcommand*\fontaxes@warn@undecodable[1]{}
     \TF@PackageInfoNoLine{Silenced fontaxes command %
     \string\fontaxes@warn@undecodable}
   }{}

This still produces the errors.

How can I disable the fontaxes warnings?

1
  • @Werner Wow, that's perfect. Thanks very much. – simont Aug 7 '13 at 6:54
5

You have a couple of options here:

  1. Following some guidelines in How do I get rid of particular pdftex warning message?, the silence package provides some assistance. By adding

    \usepackage{silence}% http://ctan.org/pkg/silence
    \WarningFilter{fontaxes}{I don't know how to decode}
    

    to you document preamble, silence will filter out warnings from the fontaxes package that starts with "I don't know how to decode".

  2. Examine the code contained in fontaxes.dtx in search of the warning to find:

    \newcommand*\fontaxes@warn@undecodable[1]{%
      \PackageWarning{fontaxes}{I don't know how to decode\MessageBreak #1}}
    

    This is the command that spits out the warning message. You can silence the macro by making it gobble it's argument:

    \makeatletter
    \let\fontaxes@warn@undecodable\@gobble
    \makeatother
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.