1

I can't get the bibliography printed in the final pdf after I compile the main.tex file with pdfLaTeX in Kile. I'm using Mageia OS with a KDE desktop environment. This is the error I get when I try to compile the main.tex with bibtex:

[BibTeX]main.aux => main.bbl (bibtex)

[BibTeX]finished with exit code 2

I pressed the bibtex button on mybibliography.bib: that didn't work. Next, I compiled (I tried) main.tex with pdfLaTeX and got 0 errors, and a number of warnings:

LaTeX Warning: Citation 'sharbati:2009' on page 3 undefined on input line 2.

LaTeX Warning: Empty bibliography on input line 51.

LaTeX Warning: There were undefined references.

Package biblatex Warning: Please (re)run Biber on the file:(biblatex)main(biblatex)and rerun LaTeX afterwards.

  • 2
    BibTeX is used on the .aux file: either bibtex main or bibtex main.aux. Alternatively, Biber uses a .bcf file: either biber main or biber main.bcf. If you are using biblatex, you are encouraged to use Biber (add backend=biber to the options of biblatex just to be clear); but you can use BibTeX if you prefer (backend=bibtex). It sounds like you are not specifying the backend and biblatex defaults to biber, but are trying nevertheless to use bibtex. You need to check your Kile settings. If that's not the problem, you need to post a minimal example (search for MWE). – jon Aug 7 '13 at 22:11
2

Your error message indicates that you are using biblatex, which supports many different backends: bibtex, bibtex8, bibtexu, biber. It now defaults to biber, since it was designed specifically for biblatex and provides much more functionality than any bibtex-based backends. If you want to use a different backend, say bibtex, you need to inform biblatex by adding the appropriate option (among any others you also wish to use):

\usepackage[backend=bibtex]{biblatex}

There are also implications for what files need to be processed based on the backend. With bibtex, you use the .aux file to create the bibliography; the command sequence is:

latex  myfile.tex
bibtex myfile.aux
latex  myfile.tex
latex  myfile.tex 

(Note that the file extension does not need to be said explicitly, but these are the specific files that latex and bibtex are using.)

With biber it is slightly different:

latex myfile.tex
biber myfile.bcf
latex myfile.tex

(Note again that the extensions are unnecessary. Also, other packages might need a third latex run, but biber doesn't unless you do something like writing a \cite command in an entry in your .bib file. It also doesn't hurt to remind yourself that you are using biber by specifying backend=biber in your loading of biblatex.)

Now, in order to get Kile to know you are using biber instead of bibtex, you probably need to change some of the default settings. I don't use Kile and no longer have it installed, but according to the documentation, you can access these settings in 'Settings -> Configure Kile... -> Tools+Build in the General tab in the LaTeX and PDFLaTeX tools`

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.