2

I need to use \bigcupdot which according to this link is available in mnsymbol.

I downloaded the package through MikTeX Package Manager. When I open a document in Lyx, I went to Lyx Preamble and added \usepackage{mnsymbol}. When I try to write a formula it doesn't accept \bigcupdot and other stuff. How can I fix it?

4
  • 2
    I don't know Lyx, but note that the package should be loaded as MnSymbol and not mnsymbol: \usepackage{MnSymbol}. Commented Aug 9, 2013 at 9:24
  • Also, why $\usepackage{...}$ and not \usepackage{...}? Commented Aug 9, 2013 at 9:28
  • That still does not work. About the '$' they are just to emphasize its a code (after ````) they are not needed anymore. Commented Aug 9, 2013 at 10:24
  • How doesn't it work, what happens? For suggestions other than MnSymbol see tex.stackexchange.com/questions/110976/… and tex.stackexchange.com/questions/3964/… Commented Aug 9, 2013 at 12:43

1 Answer 1

1

What do you mean "doesn't accept" ? LyX doesn't support \bigcupdot so if you type it into an equation it won't show as a graphical symbol, but it will still typeset properly when you preview it as PDF, assuming that you've typed it in correctly and put the correct \usepackage{..} line in your preamble.

If you want it to look good in LyX too you have two options:

  1. Turn on instant preview. This is in preferences under display. With this turned on, every individual equation will be run through LaTeX whenever the cursor is not currently in it for editing.

  2. Instead of using \bigcupdot in your equations, create a math macro (you could call it \mybigcupdot or something) and make that map straight to \bigcupdot (put this in the "TeX" field). You can then make it display something that looks approximately correct e.g. \dot\cup (put this in the "LyX" field) so that you something a bit more visual for editing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .