I recently updated TeX Live to following version

TeX 3.1415926 (TeX Live 2013/Arch Linux)

and cannot compile any file anymore, it fails with error

$ pdflatex blab.tex 
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Arch Linux)
 restricted \write18 enabled.
---! /var/lib/texmf/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

After some research, I found out I am supposed to run fmtutil --all, but it also fails with error

$ fmtutil --all
/usr/bin/fmtutil: line 395: /usr/share/texmf/texconfig/tcfmgr: No such file or directory
fmtutil: config file `fmtutil.cnf' not found.

I tried some fixing to no avail: texhash, texconfig rehash do not change anything, and kpsewhich fmtutil.cnf yields /etc/texmf/web2c/fmtutil.cnf, as it is apparently supposed to.

  • possibly related to tex.stackexchange.com/q/127529 (similar issue, on windows though). The suggestion there is to run tlmgr update --self --all since there's been a structural update recently. – henrique Aug 9 '13 at 20:13
  • @henrique tlmgr is not included in Archlinux's version of TeX Live. I tried installing texlive-localmanager, but it does not work. – zuggg Aug 9 '13 at 20:34
  • @texenthusiast every test failed with the same error as mentioned in the post (well, with latex.fmt instead of pdflatex.fmt for latex, and xetex/xetex.fmt and xetex.pool for xetex). – zuggg Aug 9 '13 at 20:36
  • 1
    @henrique: Waiting is not necessary. Simply update the system (as suggested below: pacdiff && fmtutil-sys --all). – Simon Shine Aug 19 '13 at 23:23

The new texlive-core package requires user-intervention when updating. Running sudo pacdiff (this replaces existing files with the new .pacnew files) followed by sudo fmtutil-sys --all should fix it.

For more complete instructions, see: https://www.archlinux.org/news/texlive-2013-update-may-require-user-intervention/

| improve this answer | |
  • pacdiff is a command that only exists on Arch Linux – Kevin Panko Apr 9 '18 at 18:50
  • fmtutil-sys: command not found what to do? – banan3'14 Apr 21 '19 at 6:52

I had the same problem. I was able to solve it with moving all texlive-related .pacnew-files into their new locations. After that, the following steps solved the problem for me:

mv ~/.texlive /tmp
fmutil -all
sudo fmutil -all
sudo texhash
| improve this answer | |

I had same issue on openSUSE Tumbleweed after lasted update. I found a bug request with a workaround which helped me in my case.

touch /var/run/texlive/run-hyphen
fmtutil-sys --refresh

Don't forget to run it as superuser.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.