3

I am using kile for my latex documentation.

I wanted to keep the top level directory of tex files clean, so I have created a folder named "tmp" in the current directory and added the option to compilation as:

pdflatex --output-directory tmp

using kile's build-configuration settings.

After setting this, compilation is working very fine and the directory is clean as I desired, but the "log and messages" pane in Kile, at the bottom is not able to show the compilation status message and says:

Cannot open log file; did you run LaTeX?

Any suggestions about how do I tell KILE about new log file location??


Solution update 7-Nov-2016:

Below is a compromising work-around for this age-old, unsolved bug/problem with kile. (As the Q is closed and I only can edit the Q):

Basically the aim is to keep the current directory clean, so one may compromise to ONE additional file, more specifically a link to the .log file. Note that we already avoided a ton of other files.

So the main problem happens to be a simple bug, that the .log file is not accessible to the kile, hence complaining as above. Because kile is (in spite of the relative directory setting) still thinking that the log file should exist in the current directory to read and present its summary in "log and messages".

So I kept a symbolic link to the actual log file (which should have been created in tmp directory as a result of the option --output-directory) in the current directory, i.e.:

ln -s tmp/<filename>.log <filename>.log

This has solved the error message and everything else is normal.

8
  • please test if the following works for you: settings -> tools -> build -> PDFLaTeX -> advanced -> add ./tmp into relative dir. Save, restart Kile and test.
    – Old Nick
    Aug 11, 2013 at 10:24
  • @dcmst Thanks for the reply. This idea doesn't seem to work! (checked it twice) Aug 15, 2013 at 7:02
  • 1
    Ok, so you have two possibilities: 1) update Kile to version 3 beta1 (you need to compile the source code yourself). In that version the relative dir setting will work (tested here). 2) If you can't/don't want to update, a workaround would be to simlink only the log file in the top level directory, so that Kile will see it.
    – Old Nick
    Aug 15, 2013 at 14:24
  • Thanks @dcmst, thats a nice suggestion. So, I've been using version 2.1.3 which came automatically. Lets see if somebody can give an authentic solution dealing with kile internals... Aug 17, 2013 at 13:25
  • 4
    I'm voting to close this question as off-topic because the issue is due to a bug in Kile
    – egreg
    Jan 2, 2016 at 21:58

0

Browse other questions tagged or ask your own question.