2

I want to include both .eps and .png figures in a latex document. I did some research and find out the solution is to use dvipdfm package. However, this package does not include my .eps files in the document and report following warnings:

$ dvipdfmx test.dvi

** WARNING ** "ps: plotfile" found (not properly implemented)

I am using following headers in my .tex file:

\usepackage[dvipdfmx]{graphicx}
\input{psfig.sty}

I used to stack Latex, dvi2ps, ps2pdf command to get a .pdf file including .eps figures.

I use following command to include figures in the documet:

\begin{figure}[bthp] 
    \centerline{\psfig{figure=Results/Rsrch.Evict.eps,width=5in}}
    \caption{Total workload }
    \label{fig:ftl-map}
\end{figure}

Any idea to fix this issue ?

2

1 Answer 1

1

With pdflatex --shell-escape with TeX Live 2013 (and probably --enable-write18 in MikTeX) you can make directly a PDF including both PNG and EPS files. A MWE:

\documentclass{article}
\usepackage{graphicx}
\begin{document}
%http://creativecommons.org/about/downloads
\includegraphics{by-nd.png}
\includegraphics{by-nd.eps}
\end{document}

MWE

In place of the EPS file really is used a PDF copy generated on the fly by epstopdf (in spite that the package of the same name was not included in the preamble). Try \usepackage{epstopdf} if this MWE fail in your computer).

1
  • In MiKTeX --enable-write18 is the original switch, but --shell-escape works as well. But I had to include epstopdf explicitely in MiKTeX: tex.stackexchange.com/a/52026/9237 (just tested again: still valid).
    – Speravir
    Commented Jan 10, 2014 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .