4

I am using texmaker 4.0.3 and would like to use forward/backward search. If if right-click my tex document I get the possibility 'go to pdf', but it doesnt seem to do anything. I suppose my configurations are somehow wrong, but I couldn't figure out how to get them right. These are my configurations:

latex -synctex=1  -interaction=nonstopmode %.tex
pdflatex  -synctex=1 -interaction=nonstopmode %.tex

xelatex -synctex=1 -interaction=nonstopmode %.tex
latexmk -e "$pdflatex=q/pdflatex -synctex=1 -interaction=nonstopmode/" -pdf %.tex
bibtex %.aux
makeindex %.idx
dvips -o %.ps %.dvi
dvipdfm %.dvi
ps2pdf %.ps
mpost --interaction nonstopmode
"C:/Program Files/Asymptote/asy.exe" %.asy
"C:/Program Files/gs/gs9.05/bin/gswin32c.exe"
C:/Program Files/R/R-2.13.2/bin/R.exe CMD Sweave %.Rnw

DVI:
"C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/yap.exe" -1  -s @%.tex   %.dvi

Ps:
"C:/Program Files/Ghostgum/gsview/gsview32.exe"   %.ps

Pdf viewer:
pdf internal viewer used and additionally this statement
"C:/Program Files (x86)/Adobe/Reader 10.0/Reader/AcroRd32.exe"  %.pdf
  • Are you using the internal viewer, or Adobe Reader? Not sure if it is possible to use Reader, but the internal viewer should just work. – Torbjørn T. Aug 12 '13 at 10:43
1

Install the latest version of Texmaker. You do not need to configure anything for forward/backward search in the inbuilt pdf viewer window.

Just before jumping, do following

  1. Define your master document from Options menu
  2. Run i) pdflatex ii) bibtex iii)pdflatex iv)pdflatex. (if you are using bibliography)

Then try forward/backward search. I hope it will work.

| improve this answer | |
  • You only need one run of pdflatex for source-pdf synchronization. – Torbjørn T. Aug 12 '13 at 10:44
  • 1
    Unfortunately this does not do the trick, although I really didn't know I had to define the document as maser. – user1638145 Aug 12 '13 at 13:00
  • @Torbjorn: I am using the recent release and the internal viewer :-( – user1638145 Aug 12 '13 at 13:01
1
  1. If you have a standard LaTeX distribution (miktex, texlive or mactex), you don't have to modify the commands and the pdf synchronization works directly without modifying anything. You should reset yours settings : Option -> settings file -> reset settings)
  2. To compile the document, just use the "Quick build" command (in the "pdflatex+View pdf" mode : this is the default mode) and that's all.. You should try first with a basic document.

Note : the synchronization is made by the synctex tool and, like a lot of latex tools, synctex doesn't support spaces or special characters in the file name.

| improve this answer | |
  • I use miktex. I reset my options. If I say: switch to pdf, it actually makes the pdf viewer the active window, but it doesn't go to the correct position in the document... – user1638145 Aug 12 '13 at 16:33
  • 1
    Just take a look here : http://youtu.be/u6wPjGxUzR4?hd=1 – user27168 Aug 12 '13 at 19:06
1

Please make sure that you do not have an apostrophe in the file path. The forward and reverse lookup seems to break under this condition. For instance, "Bob's Document.tex" might compile to pdf with pdflatex, but the reverse lookup probably won't work.

| improve this answer | |
  • 1
    Thank bremen_matt, not only apostrophes cause problems but any special letter. Make sure you use only ASCII letters in your filepath, filename and in general. This fixed my problem. – Chrizzow Jul 13 '18 at 8:15
1

in options in commands tab enable the embed view of pdf. then inverse search works:)

| improve this answer | |
  • 1
    could you please elaborate a little further? this hardly feels like an answer – naphaneal Dec 2 '16 at 2:24
  • I use latest version Texmaker. in this editor open tab options then configure Texmaker then select commands tab. in this menu there is selection under the pdf viewer: Enable Embed. – mary Dec 2 '16 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.