6

I'm now using TeXstudio with my Macbook pro, MacOSX Lion system. I want to set the font of content to garamond but the command I got from the Internet is not working.

\usepackage[urw-garamond]{mathdesign}
\usepackage[T1]{fontenc}

The preview area is grey with such commands. I have downloaded the four pfb files for garamond, what should I do next?

7

You can install this font (and some others) using a special script, getnonfreefonts, provided on TUG's site. Essentially all you do is run the script (with sudo), pick the fonts you want, and watch it install them.

Once you've downloaded the script, say to your home directory, ensure that it is executable in Terminal:

cd
chmod +x getnonfreefonts

and then read the help:

./getnonfreefonts --help

While this only works for supported fonts, it is an extremely easy way to install those. Supported fonts include:

  • Arial (URW)
  • Classico (URW)
  • DayRoman (Apostrophiclabs)
  • Euro symbols (Adobe)
  • GaramondNo8 (URW)
  • GaramondNo8 Expert (Michael Sharpe)
  • LetterGothic (URW)
  • LuxiMono (Bigelow & Holmes)
  • VnTeX nonfree (Hàn Thế Thành)
  • Webomints (Galapagos Design Group)
| improve this answer | |
  • The script should meanwhile be included in TL/MacTeX, at least in the Windows version it is. – Speravir Feb 10 '14 at 1:31
  • @Speravir I wasn't sure whether I installed it separately or not so I thought it best to provide the link. I know that I have had to download it separately in the past and I know that I have not had to do so in the past, too. – cfr Feb 10 '14 at 1:40
  • OK. And yes to last remark. – Speravir Feb 10 '14 at 3:10
5

For a beginner, it may be difficult to understand the instructions of these README files, and anyway they need some adaptations to the MacOSX platform.

I've managed to install these fonts on my system. Here is how I did. I'm assuming that your TeX distribution is the usual one in Mac OS X, that is to say MacTeX.

  1. As Maurizio Loreti pointed out, you must go to CTAN and there download the ugm.zip file at http://www.ctan.org/tex-archive/fonts/urw/garamond/
  2. Unzip these files.
  3. Open the "Go to…/Goto folder" menu of the Finder and there enter /usr/local/texlive/texmf-local. It will open for you this hidden directory.
  4. move the fonts, dvips and tex folders of the umg folder to this texmf-local directory, assuming there aren't already directories (and subdirectories) with the same names there (in that case, move only the contents of each respective (sub)directories and not the directories themselves).
  5. Now for the most difficult parts: open the Terminal, and enter first this line: sudo mktexlsr. It will ask your admin password, and then your TeX distribution will update its database accordingly. It may take a while.
  6. Next, enter this line: sudo -H updmap-sys enable Map ugm.map. It will enable the font installation in your TeX distribution. It may also take a fair amount of time.
  7. By now, mathdesign should work with the urw-garamond option.

Hope that helps!

| improve this answer | |
1

You need the LaTeX support files, and maybe to enable the ugm map. Go to CTAN, and read the file tex-archive/fonts/urw/garamond/README.garamond.

| improve this answer | |
0

I have managed to install the fonts on my MacOS HighSierra (I use MacTex as Tex Distribution) by doing the following:

1) Download install-getnonfreefonts from https://www.tug.org/fonts/getnonfreefonts/ to an arbitrary directory

2) In Terminal, type

curl --remote-name https://tug.org/fonts/getnonfreefonts/install-getnonfreefonts

3) Once it's done, type

sudo texlua install-getnonfreefonts

4) To install all fonts, one can type

sudo getnonfreefonts --sys --all 

Or alternatively, type:

sudo getnonfreefonts --sys --help 

to see the different options.

5) Finally, reconfigure Lyx (Tools>Reconfigure) and the fonts are installed!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.