4

I have experiencing a strange error (?) with the grouping of author names in the bibliography with biblatex. With the following MWE the bibliography is OK: all references are found under "Vega y Carpio, Lope de":

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[style=verbose]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Book{lopedevegaarte,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {Arte nuevo de hacer comedias},
  location =     {Madrid},
  year =         1609,
}

@Book{vega-obrascompletas-prosaiii,
  author =       {Vega y Carpio, Félix Lope de},
  maintitle =    {Obras completas},
  volume =       3,
  title =        {Prosa. Epistolario, I (1604-1633)},
  location =     {Madrid},
  year =         2008,
}

@book{Vega-jerusalem,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {La Jerusalén conquistada},
  year =         1609,
  location =     {Madrid},
}

@Book{vega1997peribocana,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {Peribáñez y el comendador de Ocaña},
  year =         1997,
  editor =       {McGrady, Donald},
  introduction = {Oleza, Joan},
}

\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

BUT: If I add the following item to the bib, the bibliography is not being grouped correctly:

@book{Vega-jerusalemreprint,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {La Jerusalén conquistada},
  year =         1954,
  editor =       {Entrambasaguas, Joaquín de},
  related =      {Vega-jerusalem},
  relatedtype =  {reprintof}
}

See the image: enter image description here

Versions: Biblatex (2.6) and biber (1.6).

  • I assume you've tried pasting the entire author={...} from a working copy to the new one? I'm just thinking of characters that look the same but aren't. – Chris H Aug 13 '13 at 14:34
  • @ChrisH: yes, I did. – rogorido Aug 13 '13 at 16:04
5

This is a bug occurring in any standard style that offers the dashed option. Related entries can be separated by linebreaks, so it might take some time to settle on the best solution here. As a temporary workaround, add the following to your document preamble.

\usepackage{xpatch}
\makeatletter
\xpretobibmacro{related}{\booltrue{bbx@inset}\let\bbx@relatedhash\bbx@lasthash}{}{}
\xapptobibmacro{related}{\global\let\bbx@lasthash\bbx@relatedhash}{}{}
\makeatother
0

I tried compiling your code and it seems to work fine:

pdflatex article.tex
biber article.bcf
pdflatex article.tex

The code:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[style=verbose]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Book{lopedevegaarte,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {Arte nuevo de hacer comedias},
  location =     {Madrid},
  year =         1609,
}

@Book{vega-obrascompletas-prosaiii,
  author =       {Vega y Carpio, Félix Lope de},
  maintitle =    {Obras completas},
  volume =       3,
  title =        {Prosa. Epistolario, I (1604-1633)},
  location =     {Madrid},
  year =         2008,
}

@book{Vega-jerusalem,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {La Jerusalén conquistada},
  year =         1609,
  location =     {Madrid},
}

@Book{vega1997peribocana,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {Peribáñez y el comendador de Ocaña},
  year =         1997,
  editor =       {McGrady, Donald},
  introduction = {Oleza, Joan},
}

@book{Vega-jerusalemreprint,
  author =       {Vega y Carpio, Félix Lope de},
  title =        {La Jerusalén conquistada},
  year =         1954,
  editor =       {Entrambasaguas, Joaquín de},
  related =      {Vega-jerusalem},
  relatedtype =  {reprintof}
}

\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

The output: Output

  • thanks for your answer. With biblatex 2.6 in Texlive 2013 I'm still getting the same result I sent previously... – rogorido Aug 13 '13 at 16:07
  • Oh, I'm using Texlive 2012... You could try removing the related and relatedtype fields in the last bibitem... – Nicolas Aug 13 '13 at 16:30
  • Just checked my version of biber, and it Biber 1.5 ... So my guess is that there is a small bug in the newest release. – Nicolas Aug 13 '13 at 16:34
  • yes I can... and it works. But I would like to make use of the functionality... It seems to be a bug in biber 1.6... – rogorido Aug 13 '13 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.