I can't seem to get the reference within my {refsection}.




%Point to the bibliography db




My paragraph file




I get the first citation (dante1320) right, but the second prints as [manzoni1827]. I don't get any error when I run Bibtex concerning the missing reference. But I got it when I run Latex: LaTeX Warning: Citation 'manzoni1827' on page 2 undefined on input line 5.

1 Answer 1



If you can use biber instead of bibtex, then this will just work. Change backend=bibtex to backend=biber, and run biber filename, instead of bibtex filename.


When you use bibtex however, you will get one .aux file for each refsection, and you have to run bibtex on each of these files, not just the one for the main document. Information about this is printed in the log file as well, biblatex will write a warning to the .log file saying something like this after compiling with e.g. pdflatex:

Package biblatex Warning: Please (re)run BibTeX on the file(s):
(biblatex)                test
(biblatex)                test1-blx
(biblatex)                and rerun LaTeX afterwards.

Where test is the name of the .tex file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .